This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 831949 - NFS: Missing directories on nfs mount
NFS: Missing directories on nfs mount
Status: CLOSED WORKSFORME
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vinayaga Raman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 03:17 EDT by Sachidananda Urs
Modified: 2014-03-30 21:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-31 05:57:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sachidananda Urs 2012-06-14 03:17:49 EDT
Description of problem:

NFS client does not list all the directories. Only a subset of directories are seen. This behaviour was seen in 2 out of 8 clients I had.

stat or ls -Rl on the directory does not change anything. Still directories are missing. But currently the logs doesn't print anything, or provide any clues.

Currently workaround for this problem is to drop caches.

# sysctl vm.drop_caches=3

How reproducible:

Very rarely (I'm not able to reproduce this again).
I suggest we enhance the logs so that we can capture something next time this happens.


Also I strongly suggest we put this on FAQ, if we can come up with some reasoning on what causes such behaviour.
Comment 1 Krishna Srinivas 2012-07-30 03:28:03 EDT
Sac, it is difficult to fix this if it is not reproducible again, can you see if this can be reproduced?
Comment 2 Krishna Srinivas 2012-07-31 05:57:03 EDT
Closing the bug after discussing with Sac. It can be opened if seen again.

Note You need to log in before you can comment on or make changes to this bug.