Bug 831955 - dracut exits due to error changing net interface name
dracut exits due to error changing net interface name
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut (Show other bugs)
7.0
All Linux
high Severity high
: beta
: ---
Assigned To: dracut-maint
Bruno Goncalves
: Regression
Depends On:
Blocks: 782468
  Show dependency treegraph
 
Reported: 2012-06-14 03:48 EDT by Xiaowei Li
Modified: 2014-06-17 23:55 EDT (History)
7 users (show)

See Also:
Fixed In Version: dracut-024-25.git20130205.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:09:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
console.log (835.85 KB, text/plain)
2012-06-14 03:51 EDT, Xiaowei Li
no flags Details
bnx2i.console.log (196.83 KB, application/octet-stream)
2012-06-28 00:47 EDT, Xiaowei Li
no flags Details
console-debug.log (414.59 KB, text/plain)
2012-07-05 11:18 EDT, Xiaowei Li
no flags Details

  None (edit)
Description Xiaowei Li 2012-06-14 03:48:27 EDT
Description of problem:


Version-Release number of selected component (if applicable):
RHEL-7.0-20120612.n.1 
BCM 57712 CNA card (bnx2i) 


How reproducible:
100%

I cannot encounter this issue when installing RHEL 6.3 on my setup.

Steps to Reproduce:
1. configure the bnx2i card to boot from iscsi Lun
(HBA mode - disable, boot to target - disable)
2. perform OS installation. 
3.
  
Actual results:
dracut is dropping to debug shell and throwing the warning message
"Unable to process initqueue "


Expected results:


Additional info:
Comment 1 Xiaowei Li 2012-06-14 03:51:02 EDT
Created attachment 591760 [details]
console.log
Comment 3 Xiaowei Li 2012-06-14 04:08:07 EDT
also encounter this issue when performing OS installation to the (bnx2i offload) iscsi Lun.

I will do some investigation.
Comment 4 Harald Hoyer 2012-06-18 07:48:15 EDT
add "rd.debug" to the kernel command line to get more debug info
Comment 6 Xiaowei Li 2012-06-28 00:34:45 EDT
There are 4 BCM NIC attached to the host. udeved failed to change the net interface name. 

>>>>snip>>>
udevd[292]: error changing net interface name rename4 to eth0-renamed: File exists 
  
[  126.722275] dracut Warning: Unable to process initqueue 
[  126.724507] dracut Warning: /dev/root does not exist 
/lib/dracut-lib.sh@764(wait_for_loginit): rm -f /run/initramfs/loginit.pipe /run/initramfs/loginit.pid 
/lib/dracut-lib.sh@784(emergency_shell): '[' -e /run/initramfs/.die ']' 
/lib/dracut-lib.sh@785(emergency_shell): getargbool 1 rd.shell -y rdshell 
/lib/dracut-lib.sh@124(getargbool): local _b 
/lib/dracut-lib.sh@125(getargbool): unset _b 
/lib/dracut-lib.sh@126(getargbool): local _default 
/lib/dracut-lib.sh@127(getargbool): _default=1 
/lib/dracut-lib.sh@127(getargbool): shift 
//lib/dracut-lib.sh@128(getargbool): getarg rd.shell -y rdshell 
//lib/dracut-lib.sh@97(getarg): set +x 
//lib/dracut-lib.sh@120(getarg): return 1 
/lib/dracut-lib.sh@128(getargbool): _b= 
/lib/dracut-lib.sh@129(getargbool): '[' 1 -ne 0 -a -z '' ']' 
/lib/dracut-lib.sh@129(getargbool): _b=1 
/lib/dracut-lib.sh@130(getargbool): '[' -n 1 ']' 
/lib/dracut-lib.sh@131(getargbool): '[' 1 = 0 ']' 
/lib/dracut-lib.sh@132(getargbool): '[' 1 = no ']' 
/lib/dracut-lib.sh@133(getargbool): '[' 1 = off ']' 
/lib/dracut-lib.sh@135(getargbool): return 0 
/lib/dracut-lib.sh@786(emergency_shell): echo 'Dropping to debug shell.' 
Dropping to debug shell. 
/lib/dracut-lib.sh@787(emergency_shell): echo 
 
/lib/dracut-lib.sh@788(emergency_shell): export 'PS1=dracut:${PWD}# ' 
/lib/dracut-lib.sh@788(emergency_shell): PS1='dracut:${PWD}# ' 
/lib/dracut-lib.sh@789(emergency_shell): '[' -e /.profile ']' 
//lib/dracut-lib.sh@791(emergency_shell): getarg rd.ctty= 
//lib/dracut-lib.sh@97(getarg): set +x 
//lib/dracut-lib.sh@120(getarg): return 1 
/lib/dracut-lib.sh@791(emergency_shell): _ctty= 
/lib/dracut-lib.sh@792(emergency_shell): '[' -z '' ']' 
/lib/dracut-lib.sh@793(emergency_shell): _ctty=console 
/lib/dracut-lib.sh@794(emergency_shell): '[' -f /sys/class/tty/console/active ']' 
//lib/dracut-lib.sh@795(emergency_shell): cat /sys/class/tty/console/active 
/lib/dracut-lib.sh@795(emergency_shell): _ctty=ttyS1 
/lib/dracut-lib.sh@796(emergency_shell): _ctty=ttyS1 
/lib/dracut-lib.sh@794(emergency_shell): '[' -f /sys/class/tty/ttyS1/active ']' 
/lib/dracut-lib.sh@798(emergency_shell): _ctty=/dev/ttyS1 
/lib/dracut-lib.sh@800(emergency_shell): '[' -c /dev/ttyS1 ']' 
//lib/dracut-lib.sh@801(emergency_shell): setsid --help 
/lib/dracut-lib.sh@801(emergency_shell): strstr ' 
Usage: 
 setsid [options] <program> [arguments ...] 
 
Options: 
 -h, --help     display this help and exit 
 -V, --version  output version information and exit 
 
For more details see setsid(1).' ctty 
/lib/dracut-lib.sh@7(strstr): '[' ' 
Usage: 
 setsid [options] <program> [arguments ...] 
 
Options: 
 -h, --help     display this help and exit 
 -V, --version  output version information and exit 
 
For more details see setsid(1).' '!=' ' 
Usage: 
 setsid [options] <program> [arguments ...] 
 
Options: 
 -h, --help     display this help and exit 
 -V, --version  output version information and exit 
 
For more details see setsid(1).' ']' 
/lib/dracut-lib.sh@802(emergency_shell): setsid /bin/sh -i -l 
dracut:/# [-- MARK -- Thu Jun 28 00:30:00 2012] 
[  313.312362] kworker/u:1 used greatest stack depth: 3816 bytes left 
>>>
Comment 7 Xiaowei Li 2012-06-28 00:47:47 EDT
Created attachment 594905 [details]
bnx2i.console.log

dracut exits due to fail to rename the net interface name.

Please refer to this log for more detail.
Comment 9 Paul W. Frields 2012-07-03 10:14:21 EDT
Harald, any update on this Alpha 2 blocker bug?  Are the logs here from xiaoli sufficient for you to diagnose the issue he's seeing?
Comment 10 Harald Hoyer 2012-07-05 07:24:33 EDT
(In reply to comment #9)
> Harald, any update on this Alpha 2 blocker bug?  Are the logs here from
> xiaoli sufficient for you to diagnose the issue he's seeing?

yes, it's enough.
Comment 12 Harald Hoyer 2012-07-05 08:09:14 EDT
wwoods: any idea? 

FATAL: Module sha256 not found. 
Loading Red Hat Enterprise Linux 7.0 x86_64 installer... 
[   10.837606] initqueue used greatest stack depth: 4784 bytes left 
[   10.856667] dracut Warning: 'ksdevice=<MAC>' is deprecated. Using 'ifname=eth0:<MAC>' instead. 
dracut Warning: 'ksdevice=<MAC>' is deprecated. Using 'ifname=eth0:<MAC>' instead.
Comment 13 Xiaowei Li 2012-07-05 11:18:29 EDT
Created attachment 596423 [details]
console-debug.log

console log after adding 'rd.debug quiet'
Comment 15 Xiaowei Li 2012-07-11 12:29:35 EDT
It's the dracut issue. Can do ibft iscsi(bnx2i) boot on another host.
Comment 16 Xiaowei Li 2012-07-11 22:59:45 EDT
updated the h/w information.

dracut PASSED on the h/w with one 4*ports embedded BCM5709( 1 port for PXE installation and 1 port for the iscsi boot )

dracut FAILED on the h/w with one 2*ports embedded BCM5708(1 port for PXE installation) and one 2*ports BCM57712(1 port for iscsi boot)
Comment 20 Harald Hoyer 2013-02-26 04:15:57 EST
fixed with dracut-024-25.git20130205.el7
Comment 21 Bruno Goncalves 2013-08-05 04:59:23 EDT
The problem seems to have been fixed.

[   11.295213] bio: create slab <bio-1> at 1
[   11.337260] systemd-udevd[400]: renamed network interface em1 to enp3s0
[   11.339306] bio: create slab <bio-2> at 2
[   11.344206] systemd-udevd[401]: renamed network interface em2 to enp5s0


dracut version: dracut-031-7.git20130801.el7
Comment 22 Ludek Smid 2014-06-13 07:09:26 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.