Bug 831958 - qtcurve-kde4: has missing symbols, needs to adapt to kwin 4.8.90+ api/abi changes
qtcurve-kde4: has missing symbols, needs to adapt to kwin 4.8.90+ api/abi cha...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qtcurve-kde4 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Reznik
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: kde-4.9
  Show dependency treegraph
 
Reported: 2012-06-14 03:59 EDT by Martin Airs
Modified: 2012-07-23 08:00 EDT (History)
7 users (show)

See Also:
Fixed In Version: qtcurve-kde4-1.8.12-3.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-23 08:00:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
error message appears in xsession-errors (491 bytes, text/plain)
2012-06-14 03:59 EDT, Martin Airs
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 301728 None None None 2012-07-03 15:32:24 EDT

  None (edit)
Description Martin Airs 2012-06-14 03:59:24 EDT
Created attachment 591762 [details]
error message appears in xsession-errors

Description of problem:
cannot open workspace appearance dialog in kde-settings with qtcurve-kde4 installed. it opens and then closes immediately.

Version-Release number of selected component (if applicable):
kde 4.9.0

How reproducible:
every time

Steps to Reproduce:
1. yum install qtcurve-kde4
2. attempt to open workspace appearance dialog in kde settings
3.
  
Actual results:
opens and closes immediately

Expected results:
open normally

Additional info:
I have attached an error which appears in xsession-errors file
Comment 1 Rex Dieter 2012-06-16 08:21:47 EDT
It would appear some widget themes and/or kcm's (may?) require rebuilding against kde-4.9
Comment 2 Rex Dieter 2012-06-16 08:28:08 EDT
I see:


systemsettings(12426)/kwin KDecorationPlugins::loadPlugin: "******

The library /usr/lib64/kde4/kwin3_kde2.so has no API version
Please use the KWIN_DECORATION or future versions of kwin will no longer load this decoration!
*******" 
systemsettings(12426)/kwin KDecorationPlugins::loadPlugin: "******

The library /usr/lib64/kde4/kwin3_keramik.so has no API version
Please use the KWIN_DECORATION or future versions of kwin will no longer load this decoration!
*******" 
systemsettings(12426)/kwin KDecorationPlugins::loadPlugin: "******

The library /usr/lib64/kde4/kwin3_modernsys.so has no API version
Please use the KWIN_DECORATION or future versions of kwin will no longer load this decoration!
*******" 
systemsettings(12426)/kwin KDecorationPlugins::loadPlugin: "******

The library /usr/lib64/kde4/kwin3_qtcurve.so has no API version
Please use the KWIN_DECORATION or future versions of kwin will no longer load this decoration!
*******" 
QFile::remove: Empty or null file name
QFile::remove: Empty or null file name
QFile::remove: Empty or null file name
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id:  0x0
systemsettings: symbol lookup error: /usr/lib64/kde4/kwin3_qtcurve.so: undefined symbol: _ZNK25KCommonDecorationUnstable16clientGroupItemsEv
Comment 3 Rex Dieter 2012-06-16 08:37:48 EDT
And rock, FTBFS:

QtCurve-KDE4-1.8.12/kwin/qtcurvehandler.cpp: In member function 'virtual bool KWinQtCurve::QtCurveHandler::supports(KDecorationDefines::Ability) const':
QtCurve-KDE4-1.8.12/kwin/qtcurvehandler.cpp:258:14: error: 'AbilityClientGrouping' was not declared in this scope
Comment 4 Rex Dieter 2012-06-16 08:40:50 EDT
adjusting summary
Comment 5 Kevin Kofler 2012-06-16 14:17:00 EDT
Hmmm, I wonder if quarticurve-kwin-theme needs updating as well, though I guess not because I never implemented client grouping (nor was it implemented in the original Bluecurve-KWin, KDE 3 didn't support that feature).

The API version stuff probably means all KWin window decorations need to be at least rebuilt though.
Comment 6 Rex Dieter 2012-07-03 15:30:16 EDT
May be relevant,
http://git.reviewboard.kde.org/r/105377/
Comment 7 Rex Dieter 2012-07-03 15:45:18 EDT
Re-assigning back to kde-workspace (kwin), looks like upstream will be restoring the api to 4.8 levels


%changelog
* Tue Jul 03 2012 Rex Dieter <rdieter@fedoraproject.org> 4.8.95-2
- restore stable kdecoration API to 4.8 (#831958, kde#301728)
Comment 8 Rex Dieter 2012-07-12 13:29:09 EDT
Rats, that didn't seem to help, reopening.

Though, *maybe* rebuilding qtcurve-kde4 may work now, I'll try that.
Comment 9 Rex Dieter 2012-07-12 14:05:58 EDT
Nope, still FTBFS :(

http://koji.fedoraproject.org/koji/taskinfo?taskID=4237084

A few api items are still missing:

/builddir/build/BUILD/QtCurve-KDE4-1.8.12/kwin/qtcurveclient.cpp: In member function 'virtual void KWinQtCurve::QtCurveClient::paintEvent(QPaintEvent*)':
/builddir/build/BUILD/QtCurve-KDE4-1.8.12/kwin/qtcurveclient.cpp:856:56: error: 'clientGroupItems' was not declared in this scope
/builddir/build/BUILD/QtCurve-KDE4-1.8.12/kwin/qtcurveclient.cpp:871:51: error: 'visibleClientGroupItem' was not declared in this scope
/builddir/build/BUILD/QtCurve-KDE4-1.8.12/kwin/qtcurveclient.cpp: In member function 'virtual bool KWinQtCurve::QtCurveClient::eventFilter(QObject*, QEvent*)':
/builddir/build/BUILD/QtCurve-KDE4-1.8.12/kwin/qtcurveclient.cpp:1336:70: error: 'closeClientGroupItem' was not declared in this scope
/builddir/build/BUILD/QtCurve-KDE4-1.8.12/kwin/qtcurveclient.cpp: In member function 'bool KWinQtCurve::QtCurveClient::mouseButtonPressEvent(QMouseEvent*)':
/builddir/build/BUILD/QtCurve-KDE4-1.8.12/kwin/qtcurveclient.cpp:1372:69: error: 'displayClientMenu' was not declared in this scope
/builddir/build/BUILD/QtCurve-KDE4-1.8.12/kwin/qtcurveclient.cpp: In member function 'bool KWinQtCurve::QtCurveClient::mouseButtonReleaseEvent(QMouseEvent*)':
/builddir/build/BUILD/QtCurve-KDE4-1.8.12/kwin/qtcurveclient.cpp:1392:39: error: 'setVisibleClientGroupItem' was not declared in this scope
Comment 10 Jaroslav Reznik 2012-07-23 05:53:59 EDT
Yep, still fails during F18 mass rebuild.

Note You need to log in before you can comment on or make changes to this bug.