Bug 83205 - redirect stopped working
redirect stopped working
Status: CLOSED DUPLICATE of bug 83204
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-31 03:12 EST by Robert de Bock
Modified: 2014-08-31 19:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:51:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert de Bock 2003-01-31 03:12:33 EST
From Bugzilla Helper:
User-Agent: Opera/6.11 (Linux 2.4.18-10 i686; U)  [en]

Description of problem:
Redirects worked in version 2.3.4-0.8 of xinetd, but stopped working since version 2..7-4.7x (up2date).
The configuration used is the same, just the software changed. Here is a sample configuration:
/etc/xinetd.d/smtp
---
service smtp
{
        flags           = REUSE
        socket_type     = stream        
        wait            = no
        log_on_failure  += USERID
        disable         = no
        user            = root
        redirect        = 192.168.0.2 25
}
---
Here is a small piece of log:
---
Jan 31 08:21:55 gw xinetd[3078]: xinetd Version 2.3.7 started with libwrap options compiled in.
Jan 31 08:21:55 gw xinetd[3078]: Started working: 0 available services
Jan 31 08:21:58 gw xinetd: xinetd startup succeeded
---

As a workaround you could setup ssh to do port-redirection.

Someone already found this identical problem:
https://listman.redhat.com/pipermail/psyche-list/2002-December/008320.html

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install the new version of xinetd, using up2date or whatever tool.
2. restart xinetd and watch your logs or test the redirects.
   

Actual Results:  xinetd stopped redirecting.

Expected Results:  xinetd should redirect.

Additional info:
Comment 1 Robert de Bock 2003-01-31 03:16:22 EST

*** This bug has been marked as a duplicate of 83204 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:51:31 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.