Bug 832073 - JBoss AS Quickstarts: some of them use richfaces-bom but there is no note in README files where to find it
JBoss AS Quickstarts: some of them use richfaces-bom but there is no note in ...
Status: CLOSED DUPLICATE of bug 832096
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Errai, RichFaces, GWT (Show other bugs)
2.0.0.ER8
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Marek Novotny
Tomas Repel
jboss-as-quickstarts
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 08:55 EDT by Tomas Repel
Modified: 2012-06-20 11:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 11:03:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Repel 2012-06-14 08:55:03 EDT
Description of problem:

Helloworld JSF and Richfaces Validation quickstarts from EAP 6 distribution use org:richfaces:richfaces-bom:4.2.2.Final-redhat-1. This is not included in EAP6 maven repository distribution zip. In README files in maven configuration section, there is not mentioned any other repository to be required. The these quickstarts need repository that contains this bom (e.g. WFK2 maven repository). This should be mentioned in README files.

Version-Release number of selected component (if applicable):

WFK2 ER8
EAP6 CR1

How reproducible:

Always.

Steps to Reproduce:
1. configure maven's settings.xml according to README file of jboss-as-quickstart-richfaces-validation
2. try to package via maven
  
Actual results:

Downloading: http://repo1.maven.org/maven2/org/richfaces/richfaces-bom/4.2.2.Final-redhat-1/richfaces-bom-4.2.2.Final-redhat-1.pom
[ERROR] The build could not read 1 project -> [Help 1]
[ERROR]   
[ERROR]   The project org.jboss.as.quickstarts:jboss-as-richfaces-validation:7.1.1.CR2 (/home/trepel/jbds5cr1/firstWorkspace/jboss-as-quickstarts-2.0.0.ER8/richfaces-validation/pom.xml) has 3 errors
[ERROR]     Non-resolvable import POM: Could not find artifact org.richfaces:richfaces-bom:pom:4.2.2.Final-redhat-1 in eap6-mirror-setting (file:///home/trepel/sources/wfk-qa/build/configuration/../../../jboss-eap-6.0.0.CR1-maven-repository) @ line 61, column 25 -> [Help 2]
[ERROR]     'dependencies.dependency.version' for org.richfaces.ui:richfaces-components-ui:jar is missing. @ line 118, column 21
[ERROR]     'dependencies.dependency.version' for org.richfaces.core:richfaces-core-impl:jar is missing. @ line 122, column 21
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
[ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/UnresolvableModelException

Expected results:

It packages.
Comment 1 Karel Piwko 2012-06-14 09:08:04 EDT
Additional info:

The fix here is to align readme file with EAP/WFK quickstart split, e.g. point to combination of both EAP & WFK Maven repositories.
Comment 2 Karel Piwko 2012-06-20 11:03:18 EDT
Closing as bug 832096 encapsulates this one.

*** This bug has been marked as a duplicate of bug 832096 ***

Note You need to log in before you can comment on or make changes to this bug.