Bug 83209 - r-c-n should save before Activate/Deactivate
Summary: r-c-n should save before Activate/Deactivate
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-network (Show other bugs)
(Show other bugs)
Version: phoebe
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 81720
TreeView+ depends on / blocked
 
Reported: 2003-01-31 10:10 UTC by Warren Togami
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-10 11:29:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Warren Togami 2003-01-31 10:10:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030121

Description of problem:
If you edit an interface, for example change your static IP address, then click
Deactivate and Activate, it wont actually change your address unless you Save
first.  This is not what the user expects, and there is no visible indication of
this fact unless you check manually.

Fix?
Save settings whenever the user clicks Activate or Deactivate.  Perhaps prompt
"Do you want to save?"

Version-Release number of selected component (if applicable):
redhat-config-network-1.1.92-1

How reproducible:
Always

Steps to Reproduce:
1. Change IP address.
2. Deactivate, activate.

Actual Results:  
IP address didn't change.

Expected Results:  
User expects IP address to change, but it didn't because they didn't save prefs.

Comment 1 Harald Hoyer 2003-01-31 10:27:30 UTC
good point, thx


Note You need to log in before you can comment on or make changes to this bug.