Bug 832092 - Running cnijnet should provide URI of Canon network printer after installing the official Canon drivers
Running cnijnet should provide URI of Canon network printer after installing ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 09:43 EDT by David Batson
Modified: 2012-06-14 10:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 10:02:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Batson 2012-06-14 09:43:32 EDT
Description of problem:
Running the command /usr/lib/cups/backend/cnijnet should give the URI of a Canon network printer after installing the offical Canon drivers.  This works in Mageia 2 with the same version of CUPS as F17 (1.5.2).

The URI I discovered in Mageia 2 works in Fedora
cnijnet:/00-1E-8F-A6-5A-72
But if I did not have Mageia 2 to fall back on, I could not discover the URI.


Version-Release number of selected component (if applicable):
Cups 1.5.2

How reproducible:
Install the official Canon drivers, restart CUPS, then run the command:
# /usr/lib/cups/backend/cnijnet
After churning a few seconds, I am returned to the prompt without any output.

Steps to Reproduce:
1. Install official Canon drivers
2. Restart CUPS
3. Run: # /usr/lib/cups/backend/cnijnet
  
Actual results:
No output. No errors displayed.

Expected results:
cnijnet:/00-1E-8F-A6-5A-72

Additional info:
My Canon Network Printer model is PIXMA MG8120
How I installed the official Canon drivers is described in detail in the following forum thread:
http://forums.fedoraforum.org/showthread.php?p=1584980#post1584980
Comment 1 Jiri Popelka 2012-06-14 10:02:32 EDT
I'm afraid we can't help you with this 3rd party driver.

However gutenprint has had a driver for Canon PIXMA MG8100 since version 5.2.7.
Install it with 'yum install gutenprint-cups' and configure the printer queue for example with system-config-printer.

You can even try the gutenprint-5.2.8 from updates-testing repository (it's still not there but should be in any moment) where the Canon driver had been significantly overhauled. Once the 5.2.8 is in updates-testing you can update from 5.2.7 with:
yum --enablerepo=updates-testing update 'gutenprint*'

Note You need to log in before you can comment on or make changes to this bug.