Bug 832109 - The F5 key resets the Console button in the RHEV-M User Portal
The F5 key resets the Console button in the RHEV-M User Portal
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: spice-xpi (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hatina
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 10:24 EDT by Bill Sanford
Modified: 2016-05-31 21:31 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-09 03:20:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Sanford 2012-06-14 10:24:57 EDT
Description of problem:
I access a RHEV-M user portal and launch a VM. I then hit F5 on the user portal and refreshes with the now ACTIVE console button of the VM I just launched!

Version-Release number of selected component (if applicable):
spice-xpi-2.7-2.fc17.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Access a RHEV-M user portal and launch a VM.
2. Once the VM is launched and running, go back to the User Portal and press F5.
3.
  
Actual results:
The Console button is no longer "greyed out" and the VM will launch again closing the original window.

Expected results:
The Console button is "greyed out" and the VM will not launch again.

Additional info:
Comment 1 Peter Hatina 2012-06-18 07:28:06 EDT
This behavior can be seen on any version of spice-xpi plugin. The explanation is simple: when a web page is loaded, there is a plugin instance created. Console button is blue (active), because the plugin instance returns "connected status" of non-running process (-2). When a process is launched, the button is gray due to positive connected status variable. When you reload the page, the plugin is shut, and once again loaded. In that state, the connected status is initialized to -2 and Console button is blue (active). It is hard to pair newly loaded plugin instance to running session, because, there can be multiple instances loaded in multiple tabs, windows, etc of firefox.

Note You need to log in before you can comment on or make changes to this bug.