Bug 832144 - Couldnot install in graphics mode, system only in text mode use
Couldnot install in graphics mode, system only in text mode use
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
6.2
i386 Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
:
Depends On:
Blocks: 842499
  Show dependency treegraph
 
Reported: 2012-06-14 12:23 EDT by jthiru
Modified: 2012-07-31 02:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-12 15:13:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Vesa graphics log file (64.89 KB, text/plain)
2012-06-14 12:23 EDT, jthiru
no flags Details
Xorg configuration file (68 bytes, text/plain)
2012-06-14 12:28 EDT, jthiru
no flags Details

  None (edit)
Description jthiru 2012-06-14 12:23:04 EDT
Created attachment 591868 [details]
Vesa graphics log file

Description of problem:
Installer fails when probing for hardware, blank screen, function keys dont work.(Ivy bridge based Single Board Computer CPU: corei7-3615QE

Version-Release number of selected component (if applicable):
RHEL 6.2

How reproducible:
Everytime

Steps to Reproduce:
1. Install using RHEL 6.2 DVD media
2.
3.
  
Actual results:
Blank screen

Expected results:
installed system

Additional info:
When tried with vesa driver mode installation installation falls back to text mode only. Few modules installed and had to install using yum and tried graphics again. Failed to start graphics. Attached are the X org log files.
Comment 2 jthiru 2012-06-14 12:28:52 EDT
Created attachment 591872 [details]
Xorg configuration file
Comment 3 RHEL Product and Program Management 2012-07-10 04:53:45 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2012-07-10 22:10:00 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 5 Adam Jackson 2012-07-12 15:13:00 EDT
Log ends with:

[    20.702] (II) VESA(0): virtual address = 0xb36ef000,
	physical address = 0xb0000000, size = 67043328
[    20.710] (II) VESA(0): Setting up VESA Mode 0x118 (1024x768)
[    20.717] (II) VESA(0): VBESetVBEMode failed

The vesa driver is at the mercy of the video BIOS to set modes.  If the video BIOS call to set a display mode fails, there's nothing the X server can do to continue.  So this is either a bug in the video BIOS itself, or in the real mode emulator executing the video BIOS.

However, Ivybridge is supported by the native Intel graphics driver in RHEL 6.3, so this should not be an issue in current RHEL releases.  Closing on that basis.  If you have issues with this graphics configuration in 6.3 or newer, please file a new bug with the details.

Note You need to log in before you can comment on or make changes to this bug.