Bug 83215 - Malformed UTF-8 character (unexpected end of string)
Summary: Malformed UTF-8 character (unexpected end of string)
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl   
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-31 11:49 UTC by Marius Andreiana
Modified: 2007-04-18 16:50 UTC (History)
2 users (show)

Fixed In Version: ALL
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-12 01:18:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
small testcase (1.42 KB, text/plain)
2003-02-02 17:25 UTC, Marius Andreiana
no flags Details

Description Marius Andreiana 2003-01-31 11:49:06 UTC
When using texi2html, for example 
texi2html -monolithic gcompris.texi
the following error occurs:
Malformed UTF-8 character (unexpected end of string) at /usr/bin/texi2html line
3039, <FH001> line 147.

Comment 1 Tim Waugh 2003-01-31 11:51:09 UTC
Please supply a small test case.

Comment 2 Marius Andreiana 2003-02-02 17:25:27 UTC
Created attachment 89780 [details]
small testcase

[marius@marte C]$ texi2html gcompris.texi
Split loop at /usr/bin/texi2html line 5354, <FH001> line 56.

It stops when it finds a non-ascii UTF-8 character.

Comment 3 Marius Andreiana 2003-07-06 19:52:58 UTC
this looks like a perl bug, changing componentto perl

Comment 4 Mike A. Harris 2004-01-13 18:04:45 UTC
The bug component was changed to perl, however the assigned bug
owner wasn't changed to the perl maintainer.  This bug was fixed
in perl a while back according to other bug reports, however I
don't want to close it prematurely.

Reassigning to Chip, for him to confirm and close.

Comment 5 Alan Trulock 2004-06-30 09:13:02 UTC
I had the same problem on WHEL 3.0 and resolved it by upgrading
texi2html to the latest version from source.

Comment 6 Alan Trulock 2004-06-30 09:14:52 UTC
Err, excuse me, WBEL 3.0 (got my RHEL and WBEL confused)!

Comment 7 Jason Vas Dias 2005-11-12 01:18:07 UTC
Very sorry for the long delay in processing this bug.
This problem does not occur with perl in all current Red Hat releases.


Note You need to log in before you can comment on or make changes to this bug.