Bug 832154 - Segmentation Fault subversion 1.7.5-1
Segmentation Fault subversion 1.7.5-1
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-06-14 13:08 EDT by Mario Peshev
Modified: 2013-07-31 21:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-07-31 21:26:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
log of strace over svn (28.97 KB, text/plain)
2012-06-14 13:08 EDT, Mario Peshev
no flags Details

  None (edit)
Description Mario Peshev 2012-06-14 13:08:08 EDT
Created attachment 591884 [details]
log of strace over svn

Hello everyone,

I've installed Fedora 17 on a new notebook ThinkPad T520 last week and started configuring and adding components to it. Today I've tried to checkout a package via Subversion and I got a 'segmentation fault' problem. Then I tried simple 'svn' call only or 'svn --version' and got the same segfault failure once again.

I'm using F17 with SVN 1.7.5-1 latest from the package management repository. Tried to remove it and install once again, but didn't help. 

Reported on StackOverflow but no response yet - http://stackoverflow.com/questions/11033950/svn-1-7-5-1-segmentation-fault-everywhere

Attached is the strace of the svn command if that could help somehow.
Comment 1 Mario Peshev 2012-06-14 14:03:02 EDT
Just removed 1.7.5-1 and installed 1.7.4-6 from here - http://koji.fedoraproject.org/koji/buildinfo?buildID=314940 - which works like a charm.
Comment 2 Joe Orton 2012-06-15 05:41:56 EDT
Please get a backtrace.

# debuginfo-install subversion
# gdb /usr/bin/svn
(gdb) run
(gdb) bt
Comment 3 Joe Orton 2012-06-22 12:21:19 EDT
Mario, can you provide a backtrace using the 1.7.5 packages?  There is nothing I can do here unless you can help with aid diagnosis.  Otherwise I'll have to close out this bug.
Comment 4 Fedora End Of Life 2013-07-03 19:05:26 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 5 Fedora End Of Life 2013-07-31 21:26:46 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.