This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 83218 - Autorepeat of F*-keys and some numeric keypad keys is turned of
Autorepeat of F*-keys and some numeric keypad keys is turned of
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-31 08:50 EST by Enrico Scholz
Modified: 2007-04-18 12:50 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHL 9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-15 20:46:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
~/.Xmodmap (562 bytes, text/plain)
2003-02-03 03:51 EST, Enrico Scholz
no flags Details

  None (edit)
Description Enrico Scholz 2003-01-31 08:50:57 EST
Description of problem:

When keeping the function keys or /*-+ of the numeric keypad pressed, only one
action/character will be executed/created.


Version-Release number of selected component (if applicable):

XFree86-4.2.99.4-20030121.6


How reproducible:

100%


Steps to Reproduce:
1. start X & xterm
2. keep / pressed for some seconds

    
Actual results:

only one '/' appears


Expected results:

/////////////////
Comment 1 Mike A. Harris 2003-02-02 18:32:53 EST
I'm unable to reproduce this.  I'm getting as many other people as I can
muster up to also test it to see if anyone at all out there can reproduce
it first though.
Comment 2 Enrico Scholz 2003-02-03 03:51:19 EST
Created attachment 89798 [details]
~/.Xmodmap

Strange; I see it at least on 4 machines. They are differing from the RH beta
in the following points:

- an ~/.Xmodmap file (see attachment)
- Gnome1 desktop-environment


The "InputDevice" in /etc/X11/XF86Config-4 on one of the affected machines is

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver	    "keyboard"
	Option	    "XkbLayout" "us"
	Option	    "XkbModel" "pc105"
EndSection
Comment 3 Mike A. Harris 2003-02-03 07:03:11 EST
Well those are rather IMHO significant "differences" from the Red Hat
beta.  Can you reproduce this problem on a stock phoebe system without
any addons or customizations?  ie: no GNOME 1, no custom Xmodmap files,
no custom anything?

I don't want to research this further until I know we're playing on an
even field here, in particular because nobody has been able to reproduce
this so far.
Comment 4 Enrico Scholz 2003-02-03 07:23:02 EST
I can reproduce it without Gnome1 and/or a custom ~/.Xmodmap file:

| $ X &
| $ DISPLAY=:0 xterm
Comment 5 Charles R. Anderson 2003-02-03 11:51:25 EST
Confirmed here:

XFree86-4.2.99.4-20030129.1

X &
DISPLAY=:0.0 xterm &

/*-+ on the numeric keypad won't repeat.  Other keys on the keypad do repeat,
including numbers when numlock is turned on.  /*-+ on the normal part of the
keyboard do repeat.  Tried "xset r on" with no change.
Comment 6 Mike A. Harris 2003-02-03 11:58:40 EST
Ok, I've done a completely fresh install of the latest tree, and I can
now reproduce this with XFree86-4.2.99.4-20030129.4.  Reporting bug upstream.
Comment 7 Mike A. Harris 2003-04-15 20:46:58 EDT
Ivan Pascal found and fixed this issue quite a while ago, which got into
4.3.0, and should be fixed and working in Red Hat Linux 9.

I just tested my 9 box, and the / * - + keys on the numeric keypad, and the
Fx keys autorepeat ok in xev.

Closing bug as fixed in CURRENTRELEASE of RHL 9.  If the problem comes back,
report the bug upstream at http://bugs.xfree86.org, and reopen this bug and
put the upstream bug report URL here and I'll track it.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.