Bug 832192 - Can't select Release Version for system after enabling repositories, syncing, promoting
Can't select Release Version for system after enabling repositories, syncing,...
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Tom McKay
Katello QA List
: TestBlocker, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 15:48 EDT by Jeff Weiss
Modified: 2014-11-09 17:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-26 10:41:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Weiss 2012-06-14 15:48:00 EDT
Description of problem:


Version-Release number of selected component (if applicable):
Katello Version: 0.2.40-1.git.77.2f4983a.el6_3

How reproducible:


Steps to Reproduce:
1. Upload the fake manifest http://inecas.fedorapeople.org/fakerepos/cds/fake-manifest-syncable.zip
2. Enable repositories for "Nature Enterprise x86_64 6Server"
                           "Nature Enterprise x86_64 5Server"
                           "Nature Enterprise x86_64 16"
3. Create an environment if you don't have one already (with prior of Library)
4. Create a system via CLI/API in that environment
5. Edit the system details page, select "16" for Release Version
  
Actual results:
Can't select, dropdown is empty

Expected results:
Versions are present in the dropdown

Additional info:
Even if you sync and promote the repos into your environment, it doesn't seem to help.  However I was able to see Release Versions in the dropdown for real systems that actually registered with rhsm.
Comment 1 Tom McKay 2012-09-10 10:12:45 EDT
This works for me. Be sure to promote the content to the environment the system is in, not just enable repos.

Note You need to log in before you can comment on or make changes to this bug.