Bug 832196 - vdsm missing from ovirt node iso
vdsm missing from ovirt node iso
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
3.1 RC
Unspecified Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Mike Burns
:
Depends On: 832230
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 15:57 EDT by Robert Middleswarth
Modified: 2016-04-26 19:42 EDT (History)
15 users (show)

See Also:
Fixed In Version: 2.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 832230 (view as bug list)
Environment:
Last Closed: 2012-08-09 07:48:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Missing Directory Error (9.60 KB, image/png)
2012-06-14 15:57 EDT, Robert Middleswarth
no flags Details

  None (edit)
Description Robert Middleswarth 2012-06-14 15:57:08 EDT
Created attachment 591919 [details]
Missing Directory Error

Description of problem:
[Error 2] No such file or directory" '/etc/pki/vdsm/certs/cacert.pem'

Version-Release number of selected component (if applicable):
ovirt-node-iso-2.4.0-1.0.fc17.iso

How reproducible:
Second try gave me a white screen and had to hit power the power button to anything.

Repeatable after reboot.

Steps to Reproduce:
1. Select oVirt Enginue
2. Enter Enginue info.
3. Apply changes.
  
Actual results:
Getting errors and the system stops repling.  Never regesters with the engine.

Expected results:
Regesters to the engine

Additional info:
Comment 1 Mike Burns 2012-06-14 16:05:28 EDT
Douglas,  Looks like an issue with vdsm rather than ovirt-node, but feel free to assign back if you disagree.
Comment 2 Dennis Jacobfeuerborn 2012-06-14 18:40:30 EDT
I'm seeing this too. When I just enter the IP of the node I don't get an error and only the mentioned GUI issues. Hitting f12 "resets" the infterface though and it becomes usable again.

I got the certificate issues initially but not after I tried registering the node from the engine side. Apparently setting the optional password for this on the node works and the node appears under Hosts in the engine gui but the initialization fails with "Host installation failed. Fix installation issues and try to Re-Install".
Comment 3 Douglas Schilling Landgraf 2012-06-14 18:51:45 EDT
Hi Mike,

     I have reproduced the report (Thanks Robert). VDSM package is not automatically installed in the node as we talked over IRC. In that case, /etc/pki/vdsm/ won't be created and will affect TUI.

#rpm -qa | grep -i vdsm

vdsm-python-4.10.0-1.fc17.x86_64
vdsm-xmlrpc-4.10.0-1.fc17.noarch
vdsm-reg-4.10.0-1.fc17.noarch
vdsm-cli-4.10.0-1.fc17.noarch

Generated a rpm in the vdsm git tree:
# rpm -ivh vdsm-reg-4.10.0-0.32.git61ecfc0.el6.noarch.rpm 
error: Failed dependencies:
    vdsm = 4.10.0-0.32.git61ecfc0.el6 is needed by vdsm-reg-4.10.0-0.32.git61ecfc0.el6.noarch

Moving back to ovirt-node.
Comment 4 Mike Burns 2012-06-15 05:36:40 EDT
Blocked by bug 832230.

In the meantime, I've built a temporary sanlock package that I will upload to ovirt.org repos and regenerate the ISO image with those packages to ensure that vdsm is included
Comment 5 Dennis Jacobfeuerborn 2012-06-15 09:53:09 EDT
I just tested this again with this image:
http://ovirt.org/releases/beta/binary/ovirt-node-iso-2.4.0-1.1.fc17.iso

The initial registration from the node side now works though in the engine it then show "install failed".

Is there a way to get shell access to the node or a way to get access to the log files directly? There are tracebacks in the vdsm-reg.log but I don't want to re-type them all by hand out of the gui.
Comment 6 Mike Burns 2012-06-15 10:08:50 EDT
logs should be viewable on the log viewer screen by pressing the F8 key (iirc)

You can drop to a shell by pressing the F2 key.

As for the actual issue of registration, i'll be filing a separate bug for that shortly.
Comment 7 Mike Burns 2012-06-24 09:04:17 EDT
Moving back to modified.  This will be fixed when a new build is available (should be in next couple days).

Note You need to log in before you can comment on or make changes to this bug.