Bug 832223 - Node 2.4.0 reports virt hardware detected but disabled
Node 2.4.0 reports virt hardware detected but disabled
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Mike Burns
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-14 18:38 EDT by Cybertimber2011
Modified: 2016-04-26 15:45 EDT (History)
8 users (show)

See Also:
Fixed In Version: 2.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 07:48:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cybertimber2011 2012-06-14 18:38:29 EDT
Description of problem:
Node (2.4.0-0.0.fc17 & 2.4.0-1.0.fc17) reports:
Virtualization hardware is unavilable.
(Virtualization hardware was detected but is disabled)

Cybertimber2009> Any fix in there for the system saying virtualization hardware was found but disabled? I checked my BIOS and it is enabled.
<Cybertimber2009> mburns, no worries man.
<RobertM> Cybertimber2009, I say that one myself but couldn't repeat
<@mburns> Cybertimber2009: afaik, that works correctly, but i don't have real hardware to test with at the moment
<Cybertimber2009> Ok.  I'll check it out once the download finishes. Give me a few :) I
<@mburns> Cybertimber2009: did you see that on the tui? or login screen? or both?
<Cybertimber2009> Login screen
<@mburns> Cybertimber2009: hmm
<@mburns> sgordon: not me
<@mburns> Cybertimber2009: looks like a bug
<Cybertimber2009> mburns, Was someone else able to confirm the same? I wasn't sure if it was isolated to my hardware or not.
<@mburns> Cybertimber2009: i confirmed in code
<@mburns> Cybertimber2009: patch was submitted to remove our dependency on libvirt running in ovirt-post
<@mburns> and we replaced virsh capabilities with a call to systemd-detect-virt
<Cybertimber2009> mburns, ahh. Well it's nothing bad if it's just a message. I assume it will still work (run VMs) though right?
<@mburns> but it was a misunderstanding of what that script does
<@mburns> Cybertimber2009: yes, should work fine


Version-Release number of selected component (if applicable):
2.4.0-0.0.fc17 & 2.4.0-1.0.fc17

How reproducible:
Always

Steps to Reproduce:
1. Install Node 2.4.0
2. Reboot
3. Stop at Login screen
  
Actual results:
oVirt Node reports that virtualization hardware is unavailable.

Expected results:
If virtualization hardware is detected, no message.
If virtualization hardware is not available or disabled, show a message.

Additional info:
Comment 1 Mike Burns 2012-06-14 18:56:38 EDT
http://gerrit.ovirt.org/5366

change to not depend on libvirt introduced this regression.  systemd-detect-virt detects if you're running in a vm, not if you're capable of running a vm.

Note You need to log in before you can comment on or make changes to this bug.