Bug 832227 - vdsm-reg needs to change default port to 443
vdsm-reg needs to change default port to 443
Status: CLOSED NEXTRELEASE
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Douglas Schilling Landgraf
Haim
infra
:
: 839821 858547 (view as bug list)
Depends On:
Blocks: 822145 848616
  Show dependency treegraph
 
Reported: 2012-06-14 19:01 EDT by Cybertimber2011
Modified: 2014-01-12 19:52 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 848616 (view as bug list)
Environment:
Last Closed: 2012-07-21 10:51:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cybertimber2011 2012-06-14 19:01:25 EDT
Description of problem:
On engine-setup, the default ports are 80 and 433.
On ovirt-node, the default port is 8443.

<Cybertimber2009> So engine-setup defaults to 80/443 instead of 8080/8433 now?
<@mburns> Cybertimber2009: yes
<Cybertimber2009> So... Node needs to be changed from default to connect yea?
* Cybertimber2009 thinks it's obvious... but wonders if they should match
* Cybertimber2009 OOB
<@mburns> Cybertimber2009: yes, but it's actually vdsm
<@mburns> they set that screen up
<@mburns> dougsland: ^^
<Cybertimber2009> ahh
<@mburns> vdsm-reg needs to change default port for engine to 443

Version-Release number of selected component (if applicable):
ovirt-engine 3.1.0_0001
ovirt-node 2.4.0-1.0.fc17


How reproducible:


Steps to Reproduce:
1. Install ovirt-engine package
2. Run "engine-setup"
3. Note default port
4. Install oVirt Node 2.4.0-1.0.fc17
5. Access "oVirt Engine" tab on TUI
6. Note default Management Server Port
  
Actual results:
Node default is 8443, engine-setup is 80/443

Expected results:
Node and engine match out of the box

Additional info:
Comment 1 Douglas Schilling Landgraf 2012-06-14 19:19:27 EDT
Hi Cybertimber2011,


   Thanks for your report, the patch is available here:
   http://gerrit.ovirt.org/#/c/5367/
Comment 2 Douglas Schilling Landgraf 2012-07-12 23:50:37 EDT
*** Bug 839821 has been marked as a duplicate of this bug. ***
Comment 3 Mike Burns 2012-07-18 10:08:05 EDT
IMO, this should be a blocker for 3.1 GA.  When running through engine setup, if you choose to let the installer configure the firewall, port 8443 and 8080 are not open.  The current version of the patch solves this by having 443 as the default, but will also try fallbacks to 8080/8443.  

Given that this is targeted primarily for 3.1, we should default to 443 and fall back to 8443 if it fails.

Current functionality is that it defaults to something which will fail with 3.1 with default firewall.
Comment 4 Mike Burns 2012-09-19 11:31:47 EDT
*** Bug 858547 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.