Bug 832319 - Missing '-s(--scaling)' in man page of rhc-app
Missing '-s(--scaling)' in man page of rhc-app
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
1.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
: Triaged
: 835774 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 02:52 EDT by Jianwei Hou
Modified: 2012-11-06 13:48 EST (History)
3 users (show)

See Also:
Fixed In Version: fork_ami_US2597_US2599_US2813_US2817_US2872_US2816_US2814_213
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 13:48:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jianwei Hou 2012-06-15 02:52:05 EDT
Description of problem:
When checking man page for "rhc-app",there is no related information of '-s' and '--scaling'

Version-Release number of selected component (if applicable):


How reproducible:
always reproducible

Steps to Reproduce:
1.type 'man rhc-app'
2.opens the man page for rhc-app
3.no '-s' and '--scaling' options is found in this man page
  
Actual results:
there is no -s --scaling options in the man page for rhc-app

Expected results:
there should be -s --scaling options in the man page and rhc-app

Additional info:
Comment 1 David O'Brien 2012-06-18 21:21:31 EDT
man pages are not part of "Docs *" components in OpenShift.


$ man rhc-create-app includes the following:

-s|--scaling
              Enable scaling for this application. This must be specified when you create the  applica-
              tion.  Scaled  applications  cannot  be  converted  to  non-scaled applications. At least
              nodejs-0.6, jbossas-7, jbosseap-6.0, php-5.3, perl-5.10, python-2.6, and ruby-1.8  appli-
              cations can be scaled. OpenShift currently only supports mysql-5.1 and jenkins-client-1.4
              as embedded cartridges in scaled applications.


$ rhc-app --help includes the following (admittedly not very helpful):

-s|--scaling                   Enable scaling for this app


Scaling is already covered in the User Guide.
Comment 2 Clayton Coleman 2012-06-22 12:07:03 EDT
We are going to remove the man pages eventually.
Comment 3 Miciah Dashiel Butler Masters 2012-08-09 13:35:58 EDT
*** Bug 835774 has been marked as a duplicate of this bug. ***
Comment 4 John (J5) Palmieri 2012-10-09 12:53:04 EDT
fixed in fork
Comment 5 Jianwei Hou 2012-10-09 22:16:57 EDT
Verified on -s|--scaling

Steps:
man rhc-app
  -s|--scaling
scaling info is shown
Comment 6 Jianwei Hou 2012-10-09 23:14:06 EDT
(In reply to comment #5)
> Verified on -s|--scaling
> 
> Steps:
> man rhc-app
>   -s|--scaling
> scaling info is shown

Sorry for the typo, the verified version is fork_ami_US2597_US2599_US2813_US2817_US2872_US2816_US2814_213

Note You need to log in before you can comment on or make changes to this bug.