Bug 832321 - Keyboard suddenly looses responsivity
Keyboard suddenly looses responsivity
Status: CLOSED DUPLICATE of bug 816764
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 03:02 EDT by Dov Grobgeld
Modified: 2012-06-20 02:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 02:01:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dov Grobgeld 2012-06-15 03:02:10 EDT
Description of problem:

Everynow and then (once every few hours or days) the keyboard stops responding in X11. Actually, it does respond, but not "normally". Normally, when a key is pressed it generates an KeyPress event, and if the key is held down after the "repeat delay" (as set by xset) it generates multiple KeyPress events, and when it is released it generates a KeyRelease event. When this bug kicks in, the initial KeyPress event does not take place, but if the key is continously held down, it generates the additional repeat KeyPress events.

Version-Release number of selected component (if applicable):

Fedora 17 with all updates available as of today.

How reproducible:


Steps to Reproduce:

Unfortunately I have not yet found a scenario that triggers this bug. But after the onset of the bug the behaviour is visible in xev.

Actual results:

Initial KeyPress events do not occur when pressing a key.

Expected results:

A KeyPress should generate a KeyPress event.

Additional info:

Killing X11 and logging back on solves the problem.
Comment 1 Peter Hutterer 2012-06-20 02:01:15 EDT

*** This bug has been marked as a duplicate of bug 816764 ***

Note You need to log in before you can comment on or make changes to this bug.