Bug 83234 - Firstboot sound set up is seriously confused
Summary: Firstboot sound set up is seriously confused
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: firstboot   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
: 80884 (view as bug list)
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2003-01-31 17:55 UTC by Alan Cox
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-25 14:31:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alan Cox 2003-01-31 17:55:18 UTC
It detects the Kahula audio
It decides there is no module for it (sort of ok since its sb16 and needs hand
setup)
It says: Driver: Unknown

However it also then says "Play test sound",

If I hit that it informs me it couldnt load the unknown driver. I claim it
worked and I get
modules.conf saying

alias sound-slot-0 unknown

!!

Comment 1 Brent Fox 2003-02-05 20:25:10 UTC
Why would you say "Yes" if you didn't hear the sound?

Comment 2 Alan Cox 2003-02-05 20:29:10 UTC
Why did it put up a test audio button when it didnt know a driver to use. Thats
the real problem.

I hit it because I was going 'return, return, return, return...'  as Im sure
others will


Comment 3 Brent Fox 2003-02-05 21:25:24 UTC
Ok, gotcha.  I have changed soundcardBackend.probeCards so that it filters out
any cards whose driver kudzu reports as 'unknown'.  This will fix both firstboot
and redhat-config-soundcard.

If the card with the 'unknown' driver is the only card in the system, the
soundcard screen in firstboot will not appear at all.  If there are other cards
with valid drivers, they will appear in the soundcard screen in firstboot.

If you run redhat-config-soundcard after installation and the card with the
'unknown' driver is the only soundcard in the system, the dialog will say "No
soundcards were detected".  If there are other cards with valid drivers, they
will appear in the dialog.

This should prevent anyone from being able to press the "Play test sound" button
for a card that we already know doesn't have an available driver.  

This change should fix both this bug and bug #80884.  I'm going to dupe bug
#80884 against this report.

firstboot-1.0.5-3 and redhat-config-soundcard-1.0.4-1 should contain the fix. 
QA, please verify.

Comment 4 Brent Fox 2003-02-05 21:25:47 UTC
*** Bug 80884 has been marked as a duplicate of this bug. ***

Comment 5 Brent Fox 2003-02-05 21:27:16 UTC
Also Alan, can you test these new packages if you get a chance?  I don't
actually have a soundcard that reports 'unknown' as it's driver.  I'm pretty
sure this fix should work but I can't actually test it myself.

Comment 6 Alan Cox 2003-02-05 22:09:03 UTC
Will look for them in rawhide tomorrow


Comment 7 Brent Fox 2003-05-25 14:31:18 UTC
There is a stack of 64 bugs that have been in Modified state for a long period
of time.  I am closing these as Rawhide now.  If you find that the issue is not
fixed, please reopen this report.


Note You need to log in before you can comment on or make changes to this bug.