This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 832344 - Certificate validation fails due to multiple 'dns' entries in subjectAltName
Certificate validation fails due to multiple 'dns' entries in subjectAltName
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-httplib2 (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
: 830190 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 04:26 EDT by Richard Fearn
Modified: 2012-07-10 21:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-30 04:28:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Richard Fearn 2012-06-15 04:26:12 EDT
Description of problem:

After updating python-httplib2, an existing script that uses the Instapaper (http://www.instapaper.com/) API fails because the certificate is considered invalid.

Version-Release number of selected component (if applicable):

python-httplib2-0.7.4-2.fc16.noarch

How reproducible:

Every time the script runs

Steps to Reproduce:
1. Run script using Instapaper API
2. Get CertificateHostnameMismatch exception

Actual results:

httplib2.CertificateHostnameMismatch: Server presented certificate that does not match host www.instapaper.com: {'notAfter': 'Apr 13 00:29:37 2017 GMT', 'subjectAltName': (('DNS', 'www.instapaper.com'), ('DNS', 'instapaper.com')), 'subject': ((('serialNumber', u'kFgvILuOXBY2A3gz3DTbhKsV8Tm6x8T7'),), (('countryName', u'US'),), (('organizationName', u'www.instapaper.com'),), (('organizationalUnitName', u'GT72497635'),), (('organizationalUnitName', u'See www.rapidssl.com/resources/cps (c)11'),), (('organizationalUnitName', u'Domain Control Validated - RapidSSL(R)'),), (('commonName', u'www.instapaper.com'),))}

Additional info:

I've attached a patch to httplib2 issue 208: http://code.google.com/p/httplib2/issues/detail?id=208#c3
Comment 1 Steve Milner 2012-06-15 11:45:54 EDT
Exact same issue hit by one of my applications.
Comment 2 Richard Monk 2012-06-15 11:59:00 EDT
Reproducer:

import httplib2
h = httplib2.Http(ca_certs='/etc/pki/tls/certs/ca-bundle.crt')
resp,content = h.request("https://en.wikipedia.org")
Comment 3 Ding-Yi Chen 2012-06-21 04:28:06 EDT
*** Bug 830190 has been marked as a duplicate of this bug. ***
Comment 4 Jose Castro Leon 2012-06-21 05:10:45 EDT
Last patch works for me also.
Comment 5 Fedora Update System 2012-06-22 03:26:05 EDT
python-httplib2-0.7.4-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/python-httplib2-0.7.4-4.fc16
Comment 6 Fedora Update System 2012-06-22 03:26:20 EDT
python-httplib2-0.7.4-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-httplib2-0.7.4-4.fc17
Comment 7 Fedora Update System 2012-06-22 03:26:35 EDT
python-httplib2-0.7.4-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-httplib2-0.7.4-4.el6
Comment 8 Fedora Update System 2012-06-22 03:26:50 EDT
python-httplib2-0.7.4-4.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/python-httplib2-0.7.4-4.el5
Comment 9 Fedora Update System 2012-06-22 12:00:41 EDT
Package python-httplib2-0.7.4-4.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing python-httplib2-0.7.4-4.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-6212/python-httplib2-0.7.4-4.el6
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-06-30 04:28:00 EDT
python-httplib2-0.7.4-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-06-30 04:28:34 EDT
python-httplib2-0.7.4-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-07-10 21:31:33 EDT
python-httplib2-0.7.4-4.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2012-07-10 21:33:08 EDT
python-httplib2-0.7.4-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.