Bug 832345 - [Branding]The files in images directory is not correct when create a brand
Summary: [Branding]The files in images directory is not correct when create a brand
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Publican
Classification: Community
Component: publican
Version: 3.0
Hardware: Unspecified
OS: Linux
medium
medium
Target Milestone: 3.0
Assignee: Jeff Fearn 🐞
QA Contact: Ruediger Landmann
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-06-15 08:27 UTC by zhaiyu
Modified: 2013-01-09 10:31 UTC (History)
3 users (show)

Fixed In Version: 3.0.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-10-31 03:11:29 UTC


Attachments (Terms of Use)

Description zhaiyu 2012-06-15 08:27:33 UTC
Description of problem:

When you create a brand with publican 3.0, the publican-brand directory contains /en-US/images subdirectory, which should include image files.But the image directory is empty.

Version-Release number of selected component (if applicable):

version 3.0

How reproducible:


Steps to Reproduce:

1.Open a terminal
2.Run the following command
  $publican create_brand --name=brand_name --lang=language_code
3.Change into the publican-brand directory and check /en-US/images subdirectory contains image_left.*, image_right.*, title_logo.*, note.*, important.*, warning.*, dot.*, dot2.*, stock-go-back.*, stock-go-forward.*, stock-go-up.*, stock-home.*, h1-bg.*, watermark_draft.
  
Actual results:

The images subdirectory doesn't contain any image files.

Expected results:

All the image files are correct.

Additional info:

Comment 1 Ruediger Landmann 2012-06-18 03:51:23 UTC
A newly-created brand file should not contain these images.

The images in a brand override the default images provided by the Publican "common" brand. If you do not create custom images for your brand, Publican  uses the default images when you build a document.

Comment 2 Jeff Fearn 🐞 2012-06-20 03:51:07 UTC
This is a bug. Publican should be copying the images in brand-template/images/ to the new brand.

Looks like brand-template isn't being installed properly and the copy isn't being caught when it fails.

Comment 3 Jeff Fearn 🐞 2012-06-23 04:34:04 UTC
The brand template files were not being copied during publican install and the copy was not giving an error message when it failed.

Fixed installer and add error message.

To ssh://git.fedorahosted.org/git/publican.git
   d60b0f1..762f306  master -> master

Comment 4 Ruediger Landmann 2012-06-29 05:21:06 UTC
Verified in 3.0.t197 -- brand is created with images directory already populated


Note You need to log in before you can comment on or make changes to this bug.