Bug 832375 - Oracle DB & human tasks - taskform name can't contain whitespaces
Oracle DB & human tasks - taskform name can't contain whitespaces
Status: CLOSED DUPLICATE of bug 832436
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: jBPM Console (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Kris Verlaenen
Zuzana Krejčová
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 05:36 EDT by Zuzana Krejčová
Modified: 2016-07-31 21:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 09:21:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
exceptions thrown when trying to view the task form (6.20 KB, text/plain)
2012-06-15 05:36 EDT, Zuzana Krejčová
no flags Details

  None (edit)
Description Zuzana Krejčová 2012-06-15 05:36:45 EDT
Created attachment 592085 [details]
exceptions thrown when trying to view the task form

Description of problem:
Oracle db has some problems when using task forms with names containing whitspaces. I have a task form named "task for krisv". When testing with Oracle db (Oracle Database 11g, 11.2.0.2.0), trying to view this task form (start the process, view the task for the instance) in the jBPM Console results in exceptions: 

ERROR [org.jbpm.task.service.TaskServerHandler] (Thread-28) 
java.lang.NullPointerException
	at java.io.ObjectOutputStream$BlockDataOutputStream.getUTFLength(ObjectOutputStream.java:2106)
ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/business-central-server].[Resteasy]] (http-localhost%2F127.0.0.1-8080-4) Servlet.service() for servlet Resteasy threw exception
org.jboss.resteasy.spi.UnhandledException: java.lang.RuntimeException: Command GetTaskRequest faild due to null. Please contact task server administrator.
Caused by: java.lang.RuntimeException: Command GetTaskRequest faild due to null. Please contact task server administrator.
	at org.jbpm.task.service.TaskServerHandler.messageReceived(TaskServerHandler.java:639)


Everything up to that point runs okay, without problems. No other tested DB has such a problem. The obvious workaround is to not use whitespaces in task form names.


Version-Release number of selected component (if applicable):
BRMS 5.3 ER9
Comment 1 Marco Rietveld 2012-06-15 09:21:32 EDT

*** This bug has been marked as a duplicate of bug 832436 ***

Note You need to log in before you can comment on or make changes to this bug.