Bug 832376 - Error starting: "Unsupported major.minor version 51.0"
Error starting: "Unsupported major.minor version 51.0"
Status: CLOSED CURRENTRELEASE
Product: Topic Tool
Classification: Other
Component: FUDCon Docs Hack (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Joshua Wulf
Joshua Wulf
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 05:41 EDT by Joshua Wulf
Modified: 2014-10-19 19:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-08 08:44:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2012-06-15 05:41:00 EDT
Symptom: The server starts but TopicIndex does not deploy. The server log contains:


22:22:17,201 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-8) MSC00001: Failed to start service jboss.persistenceunit."TopicIndex.war#TopicIndex": org.jboss.msc.service.StartException in service jboss.persistenceunit."TopicIndex.war#TopicIndex": Failed to start service
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1786)
        at org.jboss.msc.service.ServiceControllerImpl$ClearTCCLTask.run(ServiceControllerImpl.java:2291)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [:1.6.0_24]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [:1.6.0_24]
        at java.lang.Thread.run(Thread.java:679) [:1.6.0_24]
Caused by: java.lang.UnsupportedClassVersionError: com/redhat/topicindex/entity/Project : Unsupported major.minor version 51.0
        at java.lang.ClassLoader.defineClass1(Native Method) [:1.6.0_24]
        at java.lang.ClassLoader.defineClass(ClassLoader.java:634) [:1.6.0_24]
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142) [:1.6.0_24]
        at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:397)
        at org.jboss.modules.ModuleClassLoader.loadClassLocal(ModuleClassLoader.java:261)
        at org.jboss.modules.ModuleClassLoader$1.loadClassLocal(ModuleClassLoader.java:76)
        at org.jboss.modules.Module.loadModuleClass(Module.java:588)
        at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:183)
        at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:358)
        at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:307)
        at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:101)
        at org.jboss.as.jpa.hibernate3.HibernateAnnotationScanner.getClassesInJar(HibernateAnnotationScanner.java:144)
        at org.hibernate.ejb.Ejb3Configuration.addScannedEntries(Ejb3Configuration.java:478)
        at org.hibernate.ejb.Ejb3Configuration.scanForClasses(Ejb3Configuration.java:851)
        at org.hibernate.ejb.Ejb3Configuration.configure(Ejb3Configuration.java:594)
        at org.hibernate.ejb.HibernatePersistence.createContainerEntityManagerFactory(HibernatePersistence.java:73)
        at org.jboss.as.jpa.service.PersistenceUnitService.createContainerEntityManagerFactory(PersistenceUnitService.java:143)
        at org.jboss.as.jpa.service.PersistenceUnitService.start(PersistenceUnitService.java:77)
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1765)
        ... 4 more

22:22:17,870 INFO  [org.jboss.as.server.controller] (DeploymentScanner-threads - 1) Deployment of "TopicIndex.war" was rolled back with failure message {"Failed services" => {"jboss.persistenceunit.\"TopicIndex.war#TopicIndex\"" => "org.jboss.msc.service.StartException in service jboss.persistenceunit.\"TopicIndex.war#TopicIndex\": Failed to start service"}}
22:22:17,927 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-2) Stopped deployment TopicIndex.war in 56ms
22:22:17,929 ERROR [org.jboss.as.deployment] (DeploymentScanner-threads - 2) {"Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-2" => {"Failed services" => {"jboss.persistenceunit.\"TopicIndex.war#TopicIndex\"" => "org.jboss.msc.service.StartException in service jboss.persistenceunit.\"TopicIndex.war#TopicIndex\": Failed to start service"}}}}


Cause: TopicIndex.war requires Java 7. The server will start with Java 6, but TopicIndex.war will only deploy successfully if the server is started with Java 7.

Fix: Use Java 7.

Note You need to log in before you can comment on or make changes to this bug.