This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 832405 - black screen on login screen after updates on 14th June
black screen on login screen after updates on 14th June
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
17
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 06:43 EDT by matmenu8
Modified: 2013-08-01 09:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 09:35:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description matmenu8 2012-06-15 06:43:33 EDT
Description of problem: After boot, screen goes black, i get no login screen. Problem started today, i can remember i did an upgrade of several x11 packages yesterday. Can't get a terminal with ctrl+alt+Fx, don't have time to start repairing/investigate at the moment.
Problem happens with kernel 3.3.7-1 and 3.4.0. restart is possible through ctrl alt del with 3.3.7, not with 3.4.0


Version-Release number of selected component (if applicable):


How reproducible: install yesterday (14.06.12) updates of xorg, restart with any kernel.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results: no login screen (goes black after boot) but monitor doesn't enter sleep state.


Additional info: Intel I5 3450 on Asrock pro4/MVP H77 with radeon HD7770
everything was fine since install 2 weeks ago. No additional packages where installed, just updates.
Comment 1 matmenu8 2012-06-16 01:52:51 EDT
it happens with official amd driver 12.6. with default fedora driver on latest kernel.
With Kernel 3.3.7-1, it starts but mouse regulary disappear.
I can't use blender anymore :(
Comment 2 matmenu8 2012-06-16 15:29:12 EDT
uninstalling amd driver in rescue mode and then reinstalling worked for kernel 3.3.7-1 but not 3.4.0-1. the latest kernel won't boot with any driver (fedora libre version or proprietary amd)
Comment 3 John Ellson 2012-07-26 23:30:28 EDT
Similar symptoms occurring with kernel-3.5.0-1.fc17.x86_64 (from koji), but OK with kernel-3.4.6-2.fc17.x86_64.

This is with NVidia proprietary drivers (NVIDIA-Linux-x86_64-304.22.run).

NVidia banner screen displays ok across dual screens, then the system hangs before displaying the gdm screen.

I believe the  only difference between working and non-working in my case is the kernel version (which isn't fully consistent with the above description).
Comment 4 John Ellson 2012-07-26 23:50:34 EDT
Also I'm not seeing a problem with kernel-3.4.6-4.fc17.x86_64.  So the hang I'm seeing seems to be caused by kernel-3.5.0-1.fc17.x86_64.
Comment 5 matmenu8 2012-07-29 12:45:45 EDT
For me, problem solved since i installed Catalyst 12.6 from rpmfusion. But i didn't upgraded to kernel 3.5, still using 3.4
Comment 6 John Ellson 2012-07-29 17:25:00 EDT
The hang is not related to the NVidia drivers - I get the same blank screen on the console of a KVM virtual host running rawhide and kernel >= 3.5.0

Just the console is hung - I can still reach the machine by ssh.
Comment 7 Shourya Sarcar 2012-08-06 12:28:30 EDT
I think this is an issue with the Radeon driver in the 3.5.0 kernel. I am not an expert and cannot comment in detail, but this is what I observed:

My system:
CPU : AMD A8-4500M APU with Radeon(tm) HD Graphics
Dedicated Gfx: VGA compatible controller: ATI Technologies Inc Device 6840

What I observed:
1. Updating to kernel.x86_64 0:3.5.0-2.fc17 (using yum) caused a black screen at bootup.
2. In recovery mode, I changed grub to take out the "rhgb quiet" options.
3. As far as the naked eye can see the scrolling, I saw that the last log before the blackout is from the Direct Rendering Manager [drm].
4. Stock F17 kernel (3.3.4-5.fc17) continues to work fine although the AMD Catalyst 12.6 driver proprietary driver is not getting installed (different story).

What I did:
1. Downloaded the 3.6.0-rc1 sources from kernel.org
2. Compiled using the .config from "kernel.x86_64 0:3.5.0-2.fc17" butremoved the Radeon driver

What I now see:
1. I am ABLE to boot in and perform normal operations
2. AMD Catalyst 12.6 does not compile against this kernel (but that is a separate issue).


Reading the notes from other users above, I gather that one maybe able to get into the system using ssh etc, but I did not try that.
Comment 8 John Ellson 2012-08-26 15:30:15 EDT
I don't see mention of fc18 updates - otherwise this sounds like issues I was having caused by the polkit Bug #841451.   Workaround was "yum reinstall polkit"

If not that, then I can't help.  My similar bug has been resolved so I'm dropping off this one.
Comment 9 Fedora End Of Life 2013-07-04 00:27:00 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 10 Fedora End Of Life 2013-08-01 09:36:06 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.