Bug 83241 - redhat-config-network gets confused with two interfaces on same device
Summary: redhat-config-network gets confused with two interfaces on same device
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-31 19:48 UTC by David Kaplan
Modified: 2014-03-17 02:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-04 01:51:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Kaplan 2003-01-31 19:48:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I have a setup where I have two ethernet interfaces (one for home, one for
office) linked to the same ethernet device.  I have set one of the interfaces to
startup on boot and the other I have set to not startup on boot. Nevertheless,
when I reboot, both interfaces get started and I always have to manually turn
one off (otherwise connections get refused from home to a machine on the office
network because it thinks it can get to office machine through ethernet
connection instead of through modem).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.create two ethernet interfaces both using the device /dev/eth0 (or whatever is
your ethernet device)
2.set one of the interfaces to startup on boot, the other to not startup on boot
3.reboot the machine after saving configuration
    

Actual Results:  On boot, both interfaces are activated

Expected Results:  Only the interface that is supposed to start on boot should
get started

Additional info:

Comment 1 Harald Hoyer 2003-02-10 11:32:06 UTC
this is an initscript bug?

Comment 2 Bill Nottingham 2003-02-11 03:15:13 UTC
Well, r-c-n hardlinks /etc/sysconfig/network-scripts/ifcfg-<device> based on
what's in the profile... if you have two devices with the same device, there's
going to be problems.


Comment 3 Bill Nottingham 2003-09-04 01:51:41 UTC
This should be fixed with current initscripts that don't look in
/etc/sysconfig/networking, I believe.


Note You need to log in before you can comment on or make changes to this bug.