Bug 832475 - undefined symbol: cholmod_l_free_dense
undefined symbol: cholmod_l_free_dense
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-cvxopt (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Conrad Meyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 09:48 EDT by Neal Becker
Modified: 2012-12-20 10:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:51:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixed python-cvxopt-setup.patch (3.94 KB, patch)
2012-06-30 21:18 EDT, Justin Blanchard
no flags Details | Diff

  None (edit)
Description Neal Becker 2012-06-15 09:48:53 EDT
Description of problem:

Traceback (most recent call last):
  File "./test_8psk_cancel_lms.py", line 1181, in <module>
    run_line (sys.argv)
  File "./test_8psk_cancel_lms.py", line 1177, in run_line
    result = run (opt, cmdline)
  File "./test_8psk_cancel_lms.py", line 503, in run
    h = design_decim (opt.len_rcv_filt, co-.01, co+.01, .01)
  File "/home/nbecker/sigproc.ndarray/design_decim.py", line 20, in design_decim
    (h, d) = design_lowpass (N, ripple, co*2*pi, sb*2*pi)
  File "/home/nbecker/sigproc.ndarray/convex_filter.py", line 25, in design_lowpass
    op(max(abs(G2*h)), [G1*h <= d1, G1*h >= 1.0/d1]).solve(solver=solver)
  File "/usr/lib64/python2.7/site-packages/cvxopt/modeling.py", line 2629, in solve
    sol = solvers.lp(c[:], G, h, A, b, solver=solver)
  File "/usr/lib64/python2.7/site-packages/cvxopt/coneprog.py", line 2795, in lp
    from cvxopt import base, blas, misc
  File "/usr/lib64/python2.7/site-packages/cvxopt/misc.py", line 21, in <module>
    from cvxopt import base, blas, lapack, cholmod, misc_solvers
ImportError: /usr/lib64/python2.7/site-packages/cvxopt/cholmod.so: undefined symbol: cholmod_l_free_dense
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Justin Blanchard 2012-06-30 21:18:07 EDT
Created attachment 595492 [details]
Fixed python-cvxopt-setup.patch

Hi all. This is caused by the way python-cvxopt-setup.patch alters cvxopt to build against the system SuiteSparse library. It deletes parts of the included SuiteSparse sources from some modules' "sources" lists, so it needs to add the corresponding system libraries to their "libraries" list.

To test, I replaced this patch with the attached version (and replaced /usr/lib -> /usr/lib64 for my own system) and rebuilt; it works now! So I believe that the upstream release is OK and that applying my changes will fix the Fedora package.

(As a quick technical note: libcholmod.so pulls in libamd.so and libcolamd.so, so linking with it should be enough to replace all of the sources deleted by python-cvxopt-setup.patch.)
Comment 2 Fedora Update System 2012-10-10 13:49:50 EDT
python-cvxopt-1.1.5-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/python-cvxopt-1.1.5-5.fc17
Comment 3 Fedora Update System 2012-10-10 13:50:07 EDT
python-cvxopt-1.1.5-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-cvxopt-1.1.5-5.fc18
Comment 4 Fedora Update System 2012-10-10 20:58:42 EDT
Package python-cvxopt-1.1.5-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-cvxopt-1.1.5-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15854/python-cvxopt-1.1.5-5.fc17
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-12-20 10:51:22 EST
python-cvxopt-1.1.5-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.