Bug 832485 - bangarang crash attempting to load/play anything (nepomuk related?)
bangarang crash attempting to load/play anything (nepomuk related?)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bangarang (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Reznik
Fedora Extras Quality Assurance
:
Depends On:
Blocks: kde-4.9
  Show dependency treegraph
 
Reported: 2012-06-15 10:16 EDT by Rex Dieter
Modified: 2012-06-29 13:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-29 13:06:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2012-06-15 10:16:16 EDT
Seems bangarang isn't happy with kde-4.8.90 and related nepomuk changes (assuming here).  I'm seeing crashes doing pretty much anything.

Application: Bangarang (bangarang), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7fb5709cf880 (LWP 7409))]

Thread 5 (Thread 0x7fb557ffe700 (LWP 7414)):
#0  0x0000003e15ce8eef in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00000039500479b4 in g_main_context_poll (n_fds=1, fds=0x7fb5500429b0, timeout=-1, context=0x7fb5500009a0, priority=<optimized out>) at gmain.c:3440
#2  g_main_context_iterate (context=context@entry=0x7fb5500009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<error reading variable: Unhandled dwarf expression opcode 0xfa>) at gmain.c:3141
#3  0x0000003950047ad4 in g_main_context_iteration (context=0x7fb5500009a0, may_block=1) at gmain.c:3207
#4  0x00000039875a4506 in QEventDispatcherGlib::processEvents (this=0x7fb5500008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x000000398757513f in QEventLoop::processEvents (this=this@entry=0x7fb557ffdc30, flags=...) at kernel/qeventloop.cpp:149
#6  0x00000039875753c8 in QEventLoop::exec (this=0x7fb557ffdc30, flags=...) at kernel/qeventloop.cpp:204
#7  0x0000003987478650 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00000000004b4ef6 in DeviceManager::run (this=0x2db9b20) at /usr/src/debug/bangarang-bangarang/src/platform/devicemanager.cpp:97
#9  0x000000398747b5eb in QThreadPrivate::start (arg=0x2db9b20) at thread/qthread_unix.cpp:307
#10 0x0000003e16807d14 in start_thread (arg=0x7fb557ffe700) at pthread_create.c:309
#11 0x0000003e15cf199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 4 (Thread 0x7fb5577fd700 (LWP 7415)):
#0  0x00007fff0d1ff827 in clock_gettime ()
#1  0x0000003e16c0410d in __GI_clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:116
#2  0x00000039874d14a4 in do_gettime (frac=0x7fb5577fca58, sec=0x7fb5577fca50) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00000039875a4d0d in QTimerInfoList::updateCurrentTime (this=this@entry=0x7fb548001f50) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00000039875a5053 in QTimerInfoList::timerWait (this=0x7fb548001f50, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00000039875a3bcc in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fb5577fcb4c) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00000039875a3c75 in timerSourcePrepare (source=source@entry=0x7fb548001ef0, timeout=timeout@entry=0x7fb5577fcb4c) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00000039500471ef in g_main_context_prepare (context=context@entry=0x7fb5480009a0, priority=priority@entry=0x7fb5577fcb98) at gmain.c:2836
#9  0x00000039500478db in g_main_context_iterate (context=context@entry=0x7fb5480009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<error reading variable: Unhandled dwarf expression opcode 0xfa>) at gmain.c:3126
#10 0x0000003950047ad4 in g_main_context_iteration (context=0x7fb5480009a0, may_block=1) at gmain.c:3207
#11 0x00000039875a4506 in QEventDispatcherGlib::processEvents (this=0x7fb5480008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0x000000398757513f in QEventLoop::processEvents (this=this@entry=0x7fb5577fccf0, flags=...) at kernel/qeventloop.cpp:149
#13 0x00000039875753c8 in QEventLoop::exec (this=0x7fb5577fccf0, flags=...) at kernel/qeventloop.cpp:204
#14 0x0000003987478650 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#15 0x0000003987555b4f in QInotifyFileSystemWatcherEngine::run (this=0x7fb550003640) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x000000398747b5eb in QThreadPrivate::start (arg=0x7fb550003640) at thread/qthread_unix.cpp:307
#17 0x0000003e16807d14 in start_thread (arg=0x7fb5577fd700) at pthread_create.c:309
#18 0x0000003e15cf199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7fb5563e3700 (LWP 7423)):
#0  0x0000003e15ce8eef in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003612831d3f in ?? () from /lib64/libpulse.so.0
#2  0x000000361282329c in pa_mainloop_poll () from /lib64/libpulse.so.0
#3  0x00000036128238f9 in pa_mainloop_iterate () from /lib64/libpulse.so.0
#4  0x00000036128239b0 in pa_mainloop_run () from /lib64/libpulse.so.0
#5  0x0000003612831cef in ?? () from /lib64/libpulse.so.0
#6  0x0000003612c42d73 in ?? () from /usr/lib64/pulseaudio/libpulsecommon-2.0.so
#7  0x0000003e16807d14 in start_thread (arg=0x7fb5563e3700) at pthread_create.c:309
#8  0x0000003e15cf199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7fb556ffc700 (LWP 7439)):
[KCrash Handler]
#5  Soprano::SocketStream::read (this=this@entry=0x7fb556ffae30, data=data@entry=0x7fb556ffae0c "", size=size@entry=4) at /usr/src/debug/soprano-2.7.57/client/socketstream.cpp:245
#6  0x00000037268136d6 in Soprano::SocketStream::readUnsignedInt32 (this=0x7fb556ffae30, i=@0x7fb556ffae0c: 0) at /usr/src/debug/soprano-2.7.57/client/socketstream.cpp:340
#7  0x0000003726815950 in Soprano::Client::ClientConnection::executeQuery (this=0x37dba00, modelId=1116998873, query=..., type=Soprano::Query::QueryLanguageSparql, userQueryLanguage=...) at /usr/src/debug/soprano-2.7.57/client/clientconnection.cpp:244
#8  0x0000003726817e83 in Soprano::Client::ClientModel::executeQuery (this=0x37c51e0, query=..., language=<optimized out>, userQueryLanguage=...) at /usr/src/debug/soprano-2.7.57/client/clientmodel.cpp:101
#9  0x0000003610054f8c in ?? () from /lib64/libnepomuk.so.4
#10 0x00000000004e21f6 in MediaQuery::executeSelect (this=<optimized out>, model=0x2dabbb0) at /usr/src/debug/bangarang-bangarang/src/platform/mediaquery.cpp:222
#11 0x0000000000568687 in SemanticsListEngine::run (this=0x37cc660) at /usr/src/debug/bangarang-bangarang/src/platform/listengines/semanticslistengine.cpp:257
#12 0x000000398747b5eb in QThreadPrivate::start (arg=0x37cc660) at thread/qthread_unix.cpp:307
#13 0x0000003e16807d14 in start_thread (arg=0x7fb556ffc700) at pthread_create.c:309
#14 0x0000003e15cf199d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fb5709cf880 (LWP 7409)):
#0  0x0000003e1680e0ad in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x0000003950082a4f in read (__nbytes=16, __buf=0x7fff0d1ec150, __fd=<optimized out>) at /usr/include/bits/unistd.h:45
#2  g_wakeup_acknowledge (wakeup=0x2760210) at gwakeup.c:212
#3  0x0000003950047539 in g_main_context_check (context=context@entry=0x2760130, max_priority=2147483647, fds=fds@entry=0x2985930, n_fds=n_fds@entry=9) at gmain.c:2980
#4  0x0000003950047952 in g_main_context_iterate (context=context@entry=0x2760130, block=block@entry=1, dispatch=dispatch@entry=1, self=<error reading variable: Unhandled dwarf expression opcode 0xfa>) at gmain.c:3143
#5  0x0000003950047ad4 in g_main_context_iteration (context=0x2760130, may_block=1) at gmain.c:3207
#6  0x00000039875a44e6 in QEventDispatcherGlib::processEvents (this=0x27313f0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#7  0x000000360c26a2ee in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#8  0x000000398757513f in QEventLoop::processEvents (this=this@entry=0x7fff0d1ec330, flags=...) at kernel/qeventloop.cpp:149
#9  0x00000039875753c8 in QEventLoop::exec (this=0x7fff0d1ec330, flags=...) at kernel/qeventloop.cpp:204
#10 0x000000398757a1b8 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#11 0x00000000004292b6 in main (argc=1, argv=0x7fff0d1ec588) at /usr/src/debug/bangarang-bangarang/src/app/main.cpp:65
Comment 1 Martin Airs 2012-06-29 12:53:55 EDT
Bangarang works for me now in 4.8.95
Comment 2 Rex Dieter 2012-06-29 13:06:59 EDT
confirmed, yay.

Note You need to log in before you can comment on or make changes to this bug.