Bug 8325 - locale and bash2 filename expansion
Summary: locale and bash2 filename expansion
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash2   
(Show other bugs)
Version: 6.1
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-10 11:08 UTC by santini
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-22 17:26:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description santini 2000-01-10 11:08:53 UTC
As reported in bug 5980 and 6000 about tcsh, the following happens also
with bash2

 % touch A B C a b c
 % echo [A-Z]
 A a B b C c
 % echo [a-z]
 a B b C C

this depends on the locale "sorting rules"; I don't know if it is a
feature, as keld@dkuug.dk says in bug 6000 report, but shurely it can be
confusing since the ascii order is clear to everybody while the ISO locale
ordering specification is not so well known and public.

The problem could be solved if "character class" would be implemented as
described in the bash2 manual. But if I try

 % touch A B C D E a b c d e
 % echo [:upper:] [:lower:]
 e e

It happens as if the 'e' between [] is matched, instead of the character
classes. Shoud the "character class" pattern be activated some how via some
options I am missing, or the fact that it is not working for me is simply a
bug ?

Comment 1 santini 2000-01-22 14:24:59 UTC
I've to ask you sorry, the last problem was a problem of escaping

	echo [[:alha::]]

works as espected...


Note You need to log in before you can comment on or make changes to this bug.