Bug 832513 - Installation on an EFI system asks for an "bootloader stage1 target device"
Installation on an EFI system asks for an "bootloader stage1 target device"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 11:26 EDT by Rafael Ávila de Espíndola
Modified: 2013-01-10 01:49 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-13 20:30:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (88.44 KB, image/png)
2012-06-15 11:26 EDT, Rafael Ávila de Espíndola
no flags Details

  None (edit)
Description Rafael Ávila de Espíndola 2012-06-15 11:26:35 EDT
Created attachment 592164 [details]
screen shot

I have created an USB boot disk using livecd-iso-to-disk with the --efi option. I booted an 27 inch imac by holding the alt key and selecting that disk.

The installation fails during partitioning as shown in the attached screenshot. The installation works if I bios boot a regular DVD and create a bios partition.
Comment 1 Jesse Keating 2012-07-13 20:30:34 EDT
On a mac the /boot/efi filesystem has to be hfs+.  We don't have UI in F17 to let the user create this, so it's best to pick auto partition but then select to review and modify.  Then you can adjust all but the /boot/efi hfs+ partition.
Comment 2 Rafael Ávila de Espíndola 2012-07-13 21:45:33 EDT
Why is this not a bug?

As you mentioned, anaconda is missing a feature and gives a terrible error message.
Comment 3 idgleep 2012-07-21 12:02:34 EDT
I spent this last 12 hours searching for this answer.  I finally went to bed and when I woke back up I put together the right google search string to finally get me here.  

The installation of Fedora 17 on my MacbookPro4,2 has been a nightmare.  Somehow, it installed in a bios-install mode ... once.  I have no idea how or why this occurred, but I had to reinstall because the system wouldn't boot and I ran back into the 'bootloader stage1' error repeatedly.

Jesse's post above described the only fix I could find.  As far as I am concerned this is a major bug.  It makes the install for a whole swath of the market a bizarre and frustrating undertaking.

Note You need to log in before you can comment on or make changes to this bug.