Bug 832521 - RFE: list utilities and other info for installing/using JON on Windows
RFE: list utilities and other info for installing/using JON on Windows
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Documentation (Show other bugs)
JON 3.1.0
Unspecified Unspecified
urgent Severity medium
: ---
: JON 3.1.1
Assigned To: Deon Ballard
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 11:51 EDT by Deon Ballard
Modified: 2014-10-23 08:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-11 07:01:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deon Ballard 2012-06-15 11:51:49 EDT
The information for using JON on Windows should be improved so that it's easier for Windows admins to run JON.

Ideas:

* Add a list of utilities on Windows that can or should be installed to administer JON. (I can only think of something like 7-zip, except for the JON tools themselves.)

* Highlight Windows-specific issues more. E.g., the pathname constraint -- long paths don't work.
Comment 1 Jeremy Davis 2012-07-12 10:44:32 EDT
Using a different zip tool is a must I think.  WinZip is good too.  I've run into problems with the default windows one twice.
Comment 2 Deon Ballard 2012-07-12 10:47:25 EDT
+1 on Winzip, then. 

Is there anything else that useful, even if it's not required? Usually when I install JON on Windows, I'm doing something really specific. So, I'm not just poking around with it, so I don't know what normal Windows users would need.
Comment 3 Jeremy Davis 2012-07-12 10:50:57 EDT
I recently ran an install with a group using windows.  The zip problem was the main issue.  One guy had some strange permissions troubles, but I didn't get time to fully explore.  I don't have ready access to a win machine to reproduce.
Comment 4 John Sanda 2012-08-13 22:16:57 EDT
Moving to ON_QA since JON 3.1.1 ER2 build is availble - https://brewweb.devel.redhat.com/buildinfo?buildID=228250

Note You need to log in before you can comment on or make changes to this bug.