Bug 832525 - Generated PNG file breaks multilib (nav_g.png)
Generated PNG file breaks multilib (nav_g.png)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: doxygen (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 831399
  Show dependency treegraph
 
Reported: 2012-06-15 12:22 EDT by Nils Philippsen
Modified: 2012-06-30 18:10 EDT (History)
2 users (show)

See Also:
Fixed In Version: doxygen-1.8.1.1-3.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 10:15:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2012-06-15 12:22:21 EDT
Description of problem:

Doxygen as of current Rawhide embeds a generated PNG file nav_g.png into HTML documentation. Using doxygen during building put a file 

Version-Release number of selected component (if applicable):
doxygen-1.8.1.1-2.fc18

Steps to Reproduce:
1. Build a package generating HTML documentation e.g. lensfun in Rawhide
2. Download i686 and x86_64 versions of the devel packages (or which ever package the documentation is in)
3. Unpack with rpm2cpio
4. Compare the documentation
  
Actual results:
nils@gibraltar:/tmp/lensfun> diff -ur */usr/share/doc
Binary files i686/usr/share/doc/lensfun-0.2.5/manual/nav_g.png and x86_64/usr/share/doc/lensfun-0.2.5/manual/nav_g.png differ

Expected results:
* no differences *

Additional info:
This file seems to be generated from doxygen at the time the documentation is generated, see HtmlGenerator::writeTabData() in src/htmlgen.cpp.
Comment 1 Ngo Than 2012-06-20 10:15:51 EDT
it's fixed in doxygen-1.8.1.1-3.fc18,
http://koji.fedoraproject.org/koji/taskinfo?taskID=4179864
Comment 2 Fedora Update System 2012-06-21 09:25:56 EDT
doxygen-1.8.1.1-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/doxygen-1.8.1.1-3.fc17
Comment 3 Fedora Update System 2012-06-30 18:10:19 EDT
doxygen-1.8.1.1-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.