Bug 83254 - SAP DB doesn't run on phoebe. Possible library problems.
SAP DB doesn't run on phoebe. Possible library problems.
Status: CLOSED UPSTREAM
Product: Red Hat Public Beta
Classification: Retired
Component: glibc (Show other bugs)
phoebe
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
http://listserv.sap.com/pipermail/sap...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-31 17:25 EST by Elias Mårtenson
Modified: 2016-11-24 10:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-17 09:43:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elias Mårtenson 2003-01-31 17:25:21 EST
Description of problem:

When trying to run SAP DB from http://www.sapdb.org/ on phoebe the database
kernel crashes. As far as I can tell, my own experiments and other people on the
SAP DB mailing list, this problem only occurs on redhat phoebe.

This doesn't prove that it's redhat's fault of course but I still want you to be
aware of the problem.

I posted a detailed problem report on the SAP DB mailing list as well. I will
include the links to the relevant entries in the mailing list archive. If you
decide to take a look at this, you can pay extra attention to the third of these
links, which among other things, contain a strack trace from the SAP DB kernel
error log file:

http://listserv.sap.com/pipermail/sapdb.general/2003-January/017200.html
http://listserv.sap.com/pipermail/sapdb.general/2003-January/017215.html
http://listserv.sap.com/pipermail/sapdb.general/2003-January/017239.html
http://listserv.sap.com/pipermail/sapdb.general/2003-January/017240.html

Note that I have tried to run everything in the C locale as well, in order to
eliminate any risk of localisation issues.

Version-Release number of selected component (if applicable):

System in redhat 7.2 and 7.3 by my own testing. Other people on the mailing list
have reported it working with redhat 8.0. Personally, I attemted a (partially
failed) upgrade to redhat 8.0 before upgrading to phoebe, and it worked for me too.

All versions of SAP DB fails. I have tried 7.3, 7.4 beta and 7.4.

How reproducible:

Every time.

Steps to Reproduce:
1. Download and install SAP DB 7.4 from http://www.sapdb.org/
2. Start the database master process ($SAPDB/indep_prog/bin/x_server)
3. Download and install the graphical database manager on a windows PC (without
this one has to run some pretty insane commands. :-) ).
4. Run the database manager and start the database installation wizard using
Instance->Install
5. Run through the installation, specifying the RH phoebe machine as the server,
and the sapdb user name and password.
6. Complete the installation of the database instance. For my tests I have used
a 400 MB file for database and a 100 MB file for log.
7. Once the last step of the installation has been reached, and all database
files has been created, the installation wizard tries to bring the database
online but it crashes with the below mentioned error in the log file.
    
Actual results:

Database server instance crashes with the following message (among others) in
the log file:

2003-01-28 20:27:33     0 ERR 11330 COREHAND ABORTING due to signal 11

Expected results:

The database should be up and running, ready to be used.

Additional info:
Comment 1 Jakub Jelinek 2003-02-03 06:36:27 EST
eip in the backtrace is in SAPdb programs.
Most probably it is a bug in SAPdb which doesn't show up with linuxthreads
but shows up with NPTL. Of course it can be a bug in glibc, but I'd prefer
to see a self contained (minimal) testcase for it from SAPdb folks if it is so.
Does it work if you export LD_ASSUME_KERNEL=2.2.5 before running the program?
Comment 2 Elias Mårtenson 2003-02-03 17:38:17 EST
I have attempted to run with the environment variable LD_ASSUME_KERNEL=2.2.5 and
I can confirm that is does indeed fix the problem.

I have passed this information back to the SAP engineers via the public mailing
list (see the URL in this bug report for the archive). I will add more
information from them on in this bug report when and if it becomes available.
Comment 3 Elias Mårtenson 2003-02-03 17:45:55 EST
The following is the message I posted to the SAP DB mailing list:

http://listserv.sap.com/pipermail/sapdb.general/2003-February/017414.html
Comment 4 Elias Mårtenson 2003-02-05 15:29:26 EST
This is the reply receieved from a SAP engineer:

> I went to test this and sure enough, setting the environment variable
> LD_ASSUME_KERNEL=2.2.5 before running x_server fixed the 
> problem! I think
> this belongs on the web page or the wiki.

http://sapdb.2scale.net/moin.cgi/SupportedPlatforms would be a good place.

> Could any SAP engineer comment on wether this might be a bug 
> in SAP DB?

We'd rather say: it's a workaround for a bug in the old thread libraries, which
is not compatible with the new libraries.

Support for NPTL depends on whether there is the possibility to detect this at
runtime, on how fast NPTL spreads through the distributions and whether SAP
customers use it.

The same is true for NGPT.

Daniel Dittmar

-- 
Daniel Dittmar
SAP DB, SAP Labs Berlin
daniel.dittmar@sap.com
http://www.sapdb.org/
Comment 5 Jakub Jelinek 2003-02-17 09:43:28 EST
It is possible to detect NPTL at runtime (in the latest NPTL builds):
see https://listman.redhat.com/pipermail/phil-list/2003-February/000568.html

Note You need to log in before you can comment on or make changes to this bug.