Bug 832544 - Installation procedure no longer requires "-p admin" argument
Installation procedure no longer requires "-p admin" argument
Status: CLOSED NOTABUG
Product: CloudForms Common
Classification: Red Hat
Component: Docs Installation Guide (Show other bugs)
1.0.0
Unspecified Unspecified
urgent Severity low
: rc
: ---
Assigned To: Shikha
ecs-bugs
:
Depends On: 824526
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 13:26 EDT by James Laska
Modified: 2016-04-27 19:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-24 13:30:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2012-06-15 13:26:59 EDT
Description of problem:

This bug is intended to track updating the installation guide to document the new required argument.

The existing (1.0) installation guide [1] documents the following Cloud Engine configuration procedure in section "3.2. Configuring CloudForms Cloud Engine"

> # aeolus-conductor

As of CloudEngine 1.0.1, the admin user account will not be created unless the following arguments are supplied.

> # aeolus-conductor -p admin

[1] https://docs.redhat.com/docs/en-US/CloudForms/1.0/html/Installation_Guide/sect-Installation_Guide-Configuring_Cloudforms_Cloud_Engine.html

Version-Release number of selected component (if applicable):
 * aeolus-configure-2.5.7-1.el6_3.noarch
 * aeolus-conductor-0.8.28-1.el6_3.noarch
Comment 2 Dan Macpherson 2012-06-24 11:53:23 EDT
This bug now depends on BZ# 824526 due to the fact that the admin profile has been removed. From the upstream:

The default admin user will be created as part of the conductor
manifest, and this will be indicated by creation of a file in
/var/lib/aeolus-configure. This will ensure the admin user does not
get created by configure after multiple configure invocations.  The
expectation is for administrative users to be managed via the web UI
(or API), not via configure.
Comment 3 Dan Macpherson 2012-06-24 13:30:47 EDT
Have reverted this back to the original text and have brewed a new version of the book (CloudForms-Installation_Guide-1.0-web-en-US-1-53.el6eng). Since nothing has changed nor requires fixing, closing this with a NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.