Bug 83257 - 'Show email source' still munges email.
'Show email source' still munges email.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-31 17:39 EST by David Woodhouse
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-31 13:52:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample mail. (2.31 KB, text/plain)
2003-01-31 17:41 EST, David Woodhouse
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 235681 None None None Never

  None (edit)
Description David Woodhouse 2003-01-31 17:39:55 EST
See attached mail. See the formatting of the 'X-Spam-Report:' header.

See how Evolution mangles it when you select 'View->Message Display->Show Email
Source'.

Bad Evo :)
Comment 1 David Woodhouse 2003-01-31 17:41:14 EST
Created attachment 89751 [details]
Sample mail.
Comment 2 Jeremy Katz 2003-01-31 17:52:35 EST
I'm failing to see how it's mangled aside from how spamassassin mangled it. 
Point me to what I'm missing here
Comment 3 David Woodhouse 2003-02-03 09:57:49 EST
This probably isn't going to come out well in this text box but...

In the attached mail, the 'X-Spam-Report:' header is nicely formatted and
readable. Each 'SPAM:' is on a new line after two spaces:

X-Spam-Report: Detailed Report
  SPAM: -------------------- Start SpamAssassin results ----------------------
  SPAM: This mail is probably spam.  The original message has been altered
  SPAM: so you can recognise or block similar unwanted mail in future.
  SPAM: See http://spamassassin.org/tag/ for more details.
  SPAM:
  SPAM: Content analysis details:   (9.60 hits, 5 required)
  SPAM: NO_REAL_NAME       (1.3 points)  From: does not include a real name
  SPAM: TO_MALFORMED       (0.6 points)  To: has a malformed address
 
Evolution displays it more like this:
X-Spam-Report: Detailed Report SPAM: -------------------- Start
        SpamAssassin results ---------------------- SPAM: This mail is probably
        spam.  The original message has been altered SPAM: so you can recognise or
        block similar unwanted mail in future. SPAM: See
        http://spamassassin.org/tag/ for more details. SPAM:  SPAM: Content
        analysis details:   (9.60 hits, 5 required) SPAM: NO_REAL_NAME       (1.3
        points)  From: does not include a real name SPAM: TO_MALFORMED       (0.6
        points)  To: has a malformed address SPAM: FROM_MALFORMED     (0.3 points) 
Comment 4 Jeremy Katz 2003-07-28 19:24:34 EDT
Is this a problem with 1.4?
Comment 5 David Woodhouse 2003-07-30 16:35:24 EDT
Yes. Sample mail was attached to this bug... does it not do it for you?
Comment 6 Jeremy Katz 2003-10-14 20:15:39 EDT
Should be fixed with the next build (1.4.5-3) I think.  Can you check it when
it's built?
Comment 7 David Woodhouse 2003-10-15 01:48:15 EDT
Will try as soon as 1.4.5-3.dwmw2.1 is built (without imap-over-ssh I can't
actually get at my mailboxen and can't tell).
Comment 8 David Woodhouse 2003-10-15 02:33:16 EDT
Nope, still munged. Does the attached test message look correct when you view it?
Comment 9 Dave Malcolm 2004-05-07 11:24:58 EDT
I tested it on 1.5.7 and it's still munged
Comment 10 Sheldon Hearn 2004-06-11 15:03:52 EDT
If you check the message as stored on disk, you'll see it was munged
on its way in from your POP3 / IMAP / ??? server.

I've tested this with Ximian Evolution 1.4.6 on a Gentoo Linux box,
and it's definitely a bug in Evolution.  When I check the message as
stored on disk on my POP3 server, the X-Spam-Report header is
well-formed.  The copy Evolution stores on disk is munged.
Comment 11 Sheldon Hearn 2004-06-11 15:46:52 EDT
There are several open tickets for this in Ximian's Bugzilla:

http://bugzilla.ximian.com/show_bug.cgi?id=35681
Comment 12 Dave Malcolm 2004-09-20 19:25:08 EDT
FWIW, I've managed to reproduce this in evolution-2.0.0
Comment 13 David Woodhouse 2005-02-11 03:36:11 EST
Still happening in 2.1.5.

See also http://david.woodhou.se/evo-ate-my-spam-report.jpeg although that's
actually a screenshot of 2.0.something. The X-Spam-Report: header is basically
unreadable due to Evolution's mangling of it.

Upstream evolution hackers seem to claim that this is acceptable because it's
syntactically equivalent after you mangle the whitespace. I'd like to hear what
their usability people think of that assertion ;)
Comment 15 Matthew Barnes 2006-12-31 13:51:26 EST
Verified that the problem still exists in evolution-data-server-1.9.4-1.fc7.

I'm resolving this bug as UPSTREAM and will update the status of the upstream
bug [1] and continue to track the problem there.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=235681

Note You need to log in before you can comment on or make changes to this bug.