Bug 832576 - $OPENSHIFT_NOSQL_DB_CTL_SCRIPT has a repair option, but the usage details don't include it
$OPENSHIFT_NOSQL_DB_CTL_SCRIPT has a repair option, but the usage details don...
Status: CLOSED WONTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 15:26 EDT by Nam Duong
Modified: 2015-05-14 21:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-19 13:19:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nam Duong 2012-06-15 15:26:13 EDT
Description of problem:

$OPENSHIFT_NOSQL_DB_CTL_SCRIPT has this usage list:
echo "Usage: $0 [start|restart|stop|status]"

But it also has a repair function that *works.  A user on IRC pointed this out, and I've verified.  We should add to the usage.
Comment 1 Clayton Coleman 2012-06-19 13:19:32 EDT
We have no plans to expose this because it's used internally on start (to fix the instance).

Note You need to log in before you can comment on or make changes to this bug.