Bug 832577 - ovirt-node can't be approved due to missing /rhev/data-center
ovirt-node can't be approved due to missing /rhev/data-center
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
unspecified
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Dan Kenigsberg
: Regression
Depends On:
Blocks: 822145
  Show dependency treegraph
 
Reported: 2012-06-15 15:27 EDT by Mike Burns
Modified: 2012-08-09 03:59 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-09 03:59:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Burns 2012-06-15 15:27:36 EDT
Description of problem:
Because of ovirt-node's readonly filesystem, directory creation at runtime has to be handled carefully.  /rhev/data-center used to be created by the vdsm rpm when it is installed.  It's now listed in vdsm.spec as %ghost which means it is *not* laid down by default.  At runtime, it fails to be created because of the read-only filesystem.  

Version-Release number of selected component (if applicable):
4.10.0-1

How reproducible:
Always (on ovirt-node)

Steps to Reproduce:
1.install node
2.register to engine
3.try to approve
  
Actual results:
fails

Expected results:
approval works correctly

Additional info:

Regression introduced by commit ee1e68d3416d8fd728df75c0a41dd3db48f9138d
Comment 1 Mike Burns 2012-06-15 15:30:53 EDT
Two possible fixes for this:

Option 1:  in vdsm.spec.in:

diff --git a/vdsm.spec.in b/vdsm.spec.in
index a2ab784..4dabd8a 100644
--- a/vdsm.spec.in
+++ b/vdsm.spec.in
@@ -473,7 +473,7 @@ exit 0
 /lib/systemd/systemd-vdsmd
 %{_unitdir}/vdsmd.service
 %endif
-%ghost %dir %attr(-, %{vdsm_user}, %{vdsm_group}) @vdsmrepo@
+%dir %attr(-, %{vdsm_user}, %{vdsm_group}) @vdsmrepo@
 %ghost %dir %attr(-, %{vdsm_user}, %{vdsm_group}) @vdsmrepo@/hsm-tasks
 %ghost %dir %attr(-, %{vdsm_user}

Option 2:  change entry in rwtab.d/vdsm from /rhev/data-center to /rhev

Both solutions should solve the problem
Comment 2 Douglas Schilling Landgraf 2012-06-15 15:49:12 EDT
Thanks Mike!!!

Here your patch in gerrit:
http://gerrit.ovirt.org/#/c/5379/
Comment 3 Federico Simoncelli 2012-06-22 07:53:05 EDT
In the ovirt-3.1 branch as: 013b2208f20d1b7ce0b894fc54a41980c0afc62f
Comment 4 Itamar Heim 2012-08-09 03:59:59 EDT
closing ON_QA bugs as oVirt 3.1 was released:
http://www.ovirt.org/get-ovirt/

Note You need to log in before you can comment on or make changes to this bug.