Bug 832587 - hunspell-en not required for Emacs 24 when it should be
hunspell-en not required for Emacs 24 when it should be
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Karel Klíč
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-15 16:43 EDT by John D. Ramsdell
Modified: 2013-03-03 18:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-11 10:15:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John D. Ramsdell 2012-06-15 16:43:10 EDT
Description of problem:

After installing emacs, visiting a file, and then enabling flyspell-mode, flyspell mode fails because hunspell cannot find a dictionary.

Version-Release number of selected component (if applicable):

Emacs 24.0.95.1
International Ispell Version 3.2.06 (but really Hunspell 1.3.2)

How reproducible:

Always

Steps to Reproduce:
1. $ sudo yum install emacs
2. $ hunspell -D

Actual results:

Can't open affix or dictionary files for dictionary named "en_US"

Expected results:

AVAILABLE DICTIONARIES (path is not mandatory for -d option):
/usr/share/myspell/en_BS
/usr/share/myspell/en_ZW
/usr/share/myspell/en_GB
/usr/share/myspell/en_NG
/usr/share/myspell/en_SG
/usr/share/myspell/en_ZA
/usr/share/myspell/en_IE
/usr/share/myspell/en_TT
/usr/share/myspell/en_AU
/usr/share/myspell/en_AG
/usr/share/myspell/en_PH
/usr/share/myspell/en_BZ
/usr/share/myspell/en_HK
/usr/share/myspell/en_NZ
/usr/share/myspell/en_GH
/usr/share/myspell/en_CA
/usr/share/myspell/en_BW
/usr/share/myspell/en_US
/usr/share/myspell/en_NA
/usr/share/myspell/en_IN
/usr/share/myspell/en_DK
/usr/share/myspell/en_JM
LOADED DICTIONARY:
/usr/share/myspell/en_US.aff
/usr/share/myspell/en_US.dic
Hunspell 1.3.2
  C-c C-c
$ 

Additional info:

Work around: $ sudo yum install hunspell-en
Comment 1 Karel Klíč 2012-07-11 10:15:19 EDT
John, thanks for the bug report.

Unfortunately I do not think that introducing the dependency on hunspell-en is a way to go.  Emacs provides many features that interact with other programs and if we would go that path we would depend on gdb, texlive, version control programs etc.  AFAIK programs using hunspell also do not depend on specific language dictionaries.

I think "yum install hunspell-en" is the right way how to solve the issue these days.  Let's consider adding hunspell-en as a dependency when RPM starts supporting optional dependencies ("Recommends").

I'm closing this issue for now.  If you have some strong arguments for introducing the dependency, feel free to reopen so we can discuss them.

Note You need to log in before you can comment on or make changes to this bug.