Bug 832679 - System does not complete suspend: fan keeps running even after display and key board etc have gone off
Summary: System does not complete suspend: fan keeps running even after display and ke...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 18
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-06-16 10:59 UTC by Ankur Sinha (FranciscoD)
Modified: 2014-04-22 17:02 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-19 11:44:01 UTC
Type: Bug


Attachments (Terms of Use)
pm-suspend.log (7.44 KB, text/x-log)
2012-06-16 10:59 UTC, Ankur Sinha (FranciscoD)
no flags Details
dmidecode output (15.62 KB, text/plain)
2012-06-16 11:01 UTC, Ankur Sinha (FranciscoD)
no flags Details
output of pm-utils-bugreport.sh (10.51 KB, text/plain)
2012-06-16 11:03 UTC, Ankur Sinha (FranciscoD)
no flags Details
pm-suspend.log after a successful hibernate and resume (9.58 KB, text/x-log)
2012-06-18 14:02 UTC, Ankur Sinha (FranciscoD)
no flags Details
fpaste --sysinfo --printonly (20.05 KB, text/plain)
2012-06-19 04:51 UTC, Ankur Sinha (FranciscoD)
no flags Details
new fpaste --sysinfo --printonly output (13.73 KB, text/plain)
2012-06-19 05:57 UTC, Ankur Sinha (FranciscoD)
no flags Details
pm-suspend.log (7.29 KB, text/x-log)
2012-11-05 04:59 UTC, Ankur Sinha (FranciscoD)
no flags Details
pm susepend log (1.85 KB, application/octet-stream)
2013-01-13 08:55 UTC, froggy
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 823121 unspecified CLOSED Cannot resume after suspend 2020-10-14 00:28:05 UTC
Red Hat Bugzilla 917494 unspecified CLOSED Hibernate does not shut off power after upgrade to kernel-3.8.3-201.fc18.x86_64 2020-10-14 00:28:05 UTC

Internal Links: 823121 917494

Description Ankur Sinha (FranciscoD) 2012-06-16 10:59:18 UTC
Created attachment 592301 [details]
pm-suspend.log

Description of problem:
Cannot resume system after suspend. The issue maybe that the laptop doesn't suspend completly:

- The fan is still running after suspend appears to complete.

Version-Release number of selected component (if applicable
Linux ankur.pc 3.4.0-1.fc17.x86_64 #1 SMP Sun Jun 3 06:35:17 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

kernel-3.3.4-5.fc17.x86_64
kernel-3.3.7-1.fc17.x86_64
kernel-3.4.0-1.fc17.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Click suspend in gnome3 user control (right hand top corner) or pm-suspend in terminal
  
Actual results:
Screen goes off. 
Attached USB HDDs appear to stop functioning
Inputs(keyboard + mouse) don't work
Fan keeps running
Cannot resume. Have to cold start


Expected results:
Should suspend and resume correctly to saved state

Comment 1 Ankur Sinha (FranciscoD) 2012-06-16 11:01:16 UTC
Created attachment 592302 [details]
dmidecode output

Comment 2 Ankur Sinha (FranciscoD) 2012-06-16 11:03:15 UTC
Created attachment 592303 [details]
output of pm-utils-bugreport.sh

Comment 3 Ankur Sinha (FranciscoD) 2012-06-16 11:07:15 UTC
Was suggested I CC mjg on this bug.

Thanks,
Ankur

Comment 4 Ankur Sinha (FranciscoD) 2012-06-18 14:02:09 UTC
Created attachment 592671 [details]
pm-suspend.log after a successful hibernate and resume

Hibernate works just fine.

Comment 5 Germán Racca 2012-06-18 16:37:51 UTC
Hi Ankur:

I saw your comments on the mailing list. I also have a Dell Vostro 3500 and I can't reproduce this bug. If I suspend from the drop-down menu in Gnome 3 then the screen goes black and the fan stops, and pressing the power button it resumes successfully. It also works when pressing the combination Fn+F1.

HTH,
Germán.

Comment 6 Ankur Sinha (FranciscoD) 2012-06-19 04:50:16 UTC
(In reply to comment #5)
> Hi Ankur:
> 
> I saw your comments on the mailing list. I also have a Dell Vostro 3500 and
> I can't reproduce this bug. If I suspend from the drop-down menu in Gnome 3
> then the screen goes black and the fan stops, and pressing the power button
> it resumes successfully. It also works when pressing the combination Fn+F1.
> 
> HTH,
> Germán.


Hi German,

Thank you for tying to reproduce this. I just tried the fn + f1 and got the same result. Does it suspend immediately for you, or does it take time? I waited for 5 minutes, and the fan kept running. 

I installed F17 beta and updated to release using yum. My system is not a stock vostro either. It's an N series, with tiny customizations, although I can't recall what they were. 

I'm attaching the output of fpaste --sysinfo --printonly. xorg.0.log looks like it has a few errors that this caught:

* Xorg errors (grep '^\[.*(EE)' /var/log/Xorg.0.log):
     [    28.981] (EE) Failed to load module "nv" (module does not exist, 0)
     [    28.981] (EE) Failed to load module "modesetting" (module does not exist, 0)
     
I could be missing a package, or a minute difference in hardware could be causing this. 

Thanks for taking the time to help out,
Regards,
Ankur

Comment 7 Ankur Sinha (FranciscoD) 2012-06-19 04:51:17 UTC
Created attachment 592819 [details]
fpaste --sysinfo --printonly

Comment 8 Ankur Sinha (FranciscoD) 2012-06-19 05:57:42 UTC
Created attachment 592831 [details]
new fpaste --sysinfo --printonly output

I've installed the complete groups and corrected the above error by installing the xorg-x11-drv{nv,modesetting} packages. The problem still persists. 

I see these two errors in dmesg that I don't know what to make of:

[   30.980137] [drm:drm_debugfs_create_files] *ERROR* Cannot create /sys/kernel/debug/dri/channel/4
[   32.251853] [drm:drm_debugfs_create_files] *ERROR* Cannot create /sys/kernel/debug/dri/channel/4

Thanks,
Ankur

Comment 9 Germán Racca 2012-06-19 21:48:36 UTC
(In reply to comment #6)
> Hi German,
> 
> Thank you for tying to reproduce this. I just tried the fn + f1 and got the
> same result. Does it suspend immediately for you, or does it take time? I
> waited for 5 minutes, and the fan kept running. 

After pressing Fn + F1 the fan stops immediately in my notebook.

> I installed F17 beta and updated to release using yum. My system is not a
> stock vostro either. It's an N series, with tiny customizations, although I
> can't recall what they were.

Mine was preupgraded from F16 to F17. Indeed, my notebook is M 480 and yours is M 560 as indicated by fpaste 'cpu model' field.

Good luck :)

Comment 10 Joni Yrjana 2012-06-21 21:23:55 UTC
I have been having similar problems since kernel update from 3.3.7 to 3.4.0 and now on 3.4.2. I am assuming the kernel update is the culprit, but haven't really tested or checked it.

IIRC with kernel 3.3.7 both suspend and hibernate worked without noticeable problems.


Now with 3.4.2-4 kernel there are problems:

Suspend does not turn fans off, and am completely unable to resume.

Hibernate does turn the computer "off", but resuming is troublesome.

When I try to turn the computer back on using the power button to resume from hibernate: monitor says no sync, hard-drive led stays on all the time, the BIOS stuff is not shown (ie. I can't get into it, no "hit the del button..." etc. are ever shown), the computer stays "forever" like that.

If I switch the power off completely by unplugging the power cord from the computer, wait for few seconds, and then plug the power back (and press the power button to turn it on), the computer will resume from hibernation correctly.


This system is not a laptop, but a desktop system, x86_64 with Nvidia drivers from rpmfusion.

Comment 11 jwk1230 2012-06-29 13:07:34 UTC
I have an HP Pavilion g Series laptop. I just installed Fedora 17 last week and am having a similar problem.  


I have an external Acer monitor which I use while I have the lid closed.

From the Gnome shutdown menu, I select Suspend.
The laptop seems to power off. 
I open the lid and press the power button once.
The laptop starts back up, but I get no activity on the laptop screen OR external monitor.

This requires that I shutdown and reboot the laptop.

If I leave the laptop idle for an extended time, the same thing happens.

Comment 12 Adam Pribyl 2012-07-03 16:45:11 UTC
This happens to me on my desktop machine too. But it started with kernel 3.4.2. With 3.3.8 this works ok. This is Athlon X2 with radeon HD 2400.

Comment 13 YK 2012-07-06 23:43:58 UTC
Maybe my problem is originating from same bug: After suspending my HP X18, waking up got impossible with kernel 3.4. After pressing the power bottom the machine powers on for seconds before it completely shuts down. Hardware failure is ruled out. Most nasty bug I've experienced.

Comment 14 Josh Boyer 2012-07-10 14:40:45 UTC
This bug is starting to gather a bunch of unrelated machine types in it.  For those of you with Nvidia hardware, there was a bugfix in the latest F17 kernel that helped certain cards with suspend/resume.  Please test 3.4.4-5 and let us know.  Also, you should be using the nouveau driver, not the nv driver in most cases.

For everyone else that is having issues, please also test the latest kernel.  If you are still having suspend/resume issues please open a new bug.  We try to keep one bug per issue and there is no guarantee two different machines with suspend/resume problems will have the same root cause bug.  The kernel team can close bugs as duplicate as needed.

Comment 15 YK 2012-07-10 15:49:04 UTC
(In reply to comment #14)
> This bug is starting to gather a bunch of unrelated machine types in it. 
> For those of you with Nvidia hardware, there was a bugfix in the latest F17
> kernel that helped certain cards with suspend/resume.  Please test 3.4.4-5
> and let us know.  Also, you should be using the nouveau driver, not the nv
> driver in most cases.
> 
> For everyone else that is having issues, please also test the latest kernel.
> If you are still having suspend/resume issues please open a new bug.  We try
> to keep one bug per issue and there is no guarantee two different machines
> with suspend/resume problems will have the same root cause bug.  The kernel
> team can close bugs as duplicate as needed.

3.4.4-5 + nouveau = Works as expected
3.4.4-5 + nv = Not working (nVidia Corporation G96 [GeForce GT 130M])

Comment 16 Matthew Garrett 2012-07-10 15:53:56 UTC
Suspend isn't expected to work unless you're using a KMS driver, so if you're not using nouveau then you're on your own.

Comment 17 Ankur Sinha (FranciscoD) 2012-07-10 19:59:26 UTC
(In reply to comment #14)
> This bug is starting to gather a bunch of unrelated machine types in it. 
> For those of you with Nvidia hardware, there was a bugfix in the latest F17
> kernel that helped certain cards with suspend/resume.  Please test 3.4.4-5
> and let us know.  Also, you should be using the nouveau driver, not the nv
> driver in most cases.
> 
> For everyone else that is having issues, please also test the latest kernel.
> If you are still having suspend/resume issues please open a new bug.  We try
> to keep one bug per issue and there is no guarantee two different machines
> with suspend/resume problems will have the same root cause bug.  The kernel
> team can close bugs as duplicate as needed.

Hi Josh, Matthew,

Unfortunately 3.4-5 does not fix it for me:

[root@ankur ~]# uname -a
Linux ankur.pc 3.4.4-5.fc17.x86_64 #1 SMP Thu Jul 5 20:20:59 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

At suspend, all the lights go off, the keyboard + mouse are off too, but the fan keeps running. The power light does not begin to blink, which it used to when supend did work in previous versions.

I'm running nouveau:

[root@ankur ~]# egrep "nouveau" /var/log/Xorg.0.log
[    30.820] (==) Matched nouveau as autoconfigured driver 0
[    30.820] (II) LoadModule: "nouveau"
[    30.820] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
[    30.820] (II) Module nouveau: vendor="X.Org Foundation"
[    30.826] (II) [drm] nouveau interface version: 1.0.0
[    31.138] (II) NOUVEAU(0): [DRI2]   DRI driver: nouveau
[    31.138] (II) NOUVEAU(0): [DRI2]   VDPAU driver: nouveau
[    33.045] (II) AIGLX: Loaded and initialized nouveau
[root@ankur ~]#

Thanks for the attempt. Please let me know if there are any additional logs that you would need to diagnose the issue better.

Please note that hibernate works as expected. (I use pm-hibernate from a terminal as root)

Regards,
Ankur

Comment 18 YK 2012-07-16 20:12:32 UTC
Hello,

I have to revoke my previous post, out of a sudden resuming from suspend doesn't work anymore. All released kernels as >kernel-3.4.* fail. I testet the rawhide kernel (kernel-3.5.0-0.rc6.git4.1.fc18.x86_64) too, but still no luck.

I think my pm-suspend.log shows some error in the last line: http://pastebin.com/YVK6Af38

I don't really know if the bug described here is somehow applicable to my problem, because other then the topic starter my computer suspends successfully first but turning on the computer it powers up for 2 seconds, than the computer completely shuts down - I have to remove my battery to be able to turn it on again. But note, with Windows I have no problems so I can rule out HW-Problems. 

So is this belongs to a new bug report?

Comment 19 Adam Pribyl 2012-07-17 12:43:54 UTC
This is definitely not a hardware problem, as 3.3.x kernels are OK. There has to be some change in the freeze-shutdown code that sets ACPI or whatever to some invalid states as fans remain on while pc suspends, it can not wake up anymore, whiel the system looks like it wakes. After shutdown the computers power off, but on power on they would not boot anymore until power is unplugged...

Comment 20 Joni Yrjana 2012-07-19 21:09:36 UTC
On my system, with the recent 3.4.5-2 kernel update, suspend and hibernate again work as expected.

Comment 21 gareth foster 2012-07-24 09:41:51 UTC
I think my desktop PC is doing this as well, also AMD based, with onboard graphics.

3.4.6-2.fc17.x86_64

If it suspends (and there's no way to stop it under Gnome 3) it can't be woken up again by any amount of mashing the keyboard or mouse. I have to press the hard reset button on the tower.

Comment 22 Ankur Sinha (FranciscoD) 2012-11-05 04:59:04 UTC
Hi Josh, Matthew,

I've updated to F18 yesterday and the problem still persists. 

Linux ankur.pc 3.6.5-2.fc18.x86_64 #1 SMP Thu Nov 1 00:39:17 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Is there some additional info I can provide to help with this bug please? (I'd really like to suspend my system :( )

Please drop me a needinfo for anything I can help with. To reiterate: the display shuts, the keyboard etc do nothing, *but* the fan keeps going. the pm-suspend log appears to think that the suspend was successful (attached). (Could it be a fan issue?)

Thanks,
Ankur

Comment 23 Ankur Sinha (FranciscoD) 2012-11-05 04:59:57 UTC
Created attachment 638321 [details]
pm-suspend.log

Comment 24 Ankur Sinha (FranciscoD) 2012-11-05 08:41:54 UTC
I've just tried 

systemctl suspend # doesn't work, same result: fan keeps running

systemctl hibernate # works like a charm

Thanks,
Ankur

Comment 25 Adam Pribyl 2012-11-05 20:48:28 UTC
In that case I would bet for an ACPI BIOS code bug. No BIOS update available?

Comment 26 Ankur Sinha (FranciscoD) 2012-11-05 22:53:15 UTC
(In reply to comment #25)
> In that case I would bet for an ACPI BIOS code bug. No BIOS update available?

Hi Adam,

I just checked. No BIOS updates available on the website for my system. Is there a way I can collect more data on the issue to confirm if it's a BIOS bug or whatever?

Thanks a bunch,
Ankur

Comment 27 Ankur Sinha (FranciscoD) 2012-11-05 23:00:13 UTC
AHH, actually I think there is a BIOS update (It wasn't showing for my service tag since it's only for Windows):

http://www.dell.com/support/drivers/us/en/19/DriverDetails/Product/vostro-3400?driverId=6W3H0&osCode=ww1&fileId=2731099204#3DOS


I'll update my BIOS asap an let you know. 


Thanks,
Ankur

Comment 28 Ankur Sinha (FranciscoD) 2012-11-06 02:15:52 UTC
Hi folks,

I've updated my BIOS to the latest version available from dell:

Libsmbios version:      2.2.28
Product Name:           Vostro 3400
Vendor:                 Dell Inc.
BIOS Version:           A10
System ID:              0x0440
Service Tag:            53SQ7BS
Express Service Code:   11113562008
Asset Tag:              
Property Ownership Tag: 


Suspend still does not work. Same result: display goes off, the power light is still on, and so is the fan. 

Thanks,
Ankur

Comment 29 Ankur Sinha (FranciscoD) 2013-01-09 11:56:59 UTC
Hello,

I'm now running 3.7.1-2.fc18.x86_64 and still cannot suspend. Hibernate works like a charm as usual. 

Any hints, additional info I can provide to help with?

Thanks,
Warm regards,
Ankur

Comment 30 froggy 2013-01-13 08:55:45 UTC
Created attachment 677645 [details]
pm susepend log

I am having the same problem. I have a Dell (d430), and after waking up from pm-suspend the system suspends again. After this second suspend I make it wake up again and it runs without a problem. I tried to uncheck "spin down hard drives", because it's runs on a ssd, but the same things happens. At some point the suspend-log says: 
"Running hook /usr/lib64/pm-utils/sleep.d/95led resume suspend:
/usr/lib64/pm-utils/sleep.d/95led resume suspend: not applicable."
and it goes into suspend mode again. I'm running 3.7.1-5.fc18.x86_64, fedora 18 xfce with rpm fusion.

Comment 31 Ankur Sinha (FranciscoD) 2013-01-14 01:17:17 UTC
Hi,

I'm not sure it's the same thing. My system doesn't complete a suspend at all. I'm updating the bug summary to avoid confusion.

Please open a new bug for your issue :)

Thanks,
Warm regards,
Ankur

Comment 32 Ankur Sinha (FranciscoD) 2013-05-19 11:44:01 UTC
I can suspend and hibernate just fine with F19. Fixed. Closing.

Comment 33 Frédéric Parrenin 2014-04-22 17:00:23 UTC
I have the same problem using F20 on a dell Vostro 3500: the system won't go completely to suspend, the fan is still runing.

Comment 34 Frédéric Parrenin 2014-04-22 17:02:16 UTC
How to re-open this bug? It seems I can't go this on bugzilla.redhat


Note You need to log in before you can comment on or make changes to this bug.