Bug 832706 - nslcd should start after named and dirsrv
nslcd should start after named and dirsrv
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nss-pam-ldapd (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nalin Dahyabhai
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-16 13:35 EDT by Kenny Root
Modified: 2013-01-18 15:43 EST (History)
3 users (show)

See Also:
Fixed In Version: nss-pam-ldapd-0.8.12-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-18 15:43:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenny Root 2012-06-16 13:35:21 EDT
Description of problem:
I run a 389 server and BIND server on the same machine as nslcd, but nslcd tries to start before dirsrv and named are able to come up

Version-Release number of selected component (if applicable):
nss-pam-ldapd-0.7.13-7.fc16.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Set up dirsrv on host
1. Set up named on host, add _ldap._tcp pointing to dirsrv
2. Set up nslcd with "uri dns"
3. Reboot machine
  
Actual results:
In /var/log/messages you get:

nslcd[2382]: nslcd: /etc/nslcd.conf:133: no servers found in DNS zone example.com

Expected results:
In /var/log/messages you should get:

nslcd[3172]: accepting connections

Additional info:
Comment 1 Dmitri Pal 2012-06-19 06:45:54 EDT
Do I get it right:
a) You configure BIND to use 389
b) You want nslcd to use BIND on the same host for the hosts map but the order in which the services start prevents you from doing it.

In general you can't arbitrarily change the order of the things because if you use nss_ldap for identities it should start as early as possible in the sequence. For your case the order should be different though. 

Since you are on F17 you might need to play with the systemd dependencies.
This issues seems more to be a configuration issue rather than a bug in either of the three components.
Comment 2 Nalin Dahyabhai 2013-01-18 15:43:34 EST
Adding "After=named.service dirsrv.target slapd.service" to the unit file, so that if you happen to be running named or openldap or 389 on the same system, systemd should wait to start nslcd until those have been brought up.

Note You need to log in before you can comment on or make changes to this bug.