Bug 832711 - [abrt] hugin-2011.5.0-0.1.20120611hg.fc17: __GI_raise: Process /usr/bin/hugin was killed by signal 6 (SIGABRT)
[abrt] hugin-2011.5.0-0.1.20120611hg.fc17: __GI_raise: Process /usr/bin/hugin...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: hugin (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bruno Postle
Fedora Extras Quality Assurance
abrt_hash:135f2b1c98a01eda918140b4f3b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-16 14:01 EDT by Patrick Bregman
Modified: 2012-06-20 15:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-17 17:53:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (6.09 KB, text/plain)
2012-06-16 14:01 EDT, Patrick Bregman
no flags Details
File: backtrace (37.56 KB, text/plain)
2012-06-16 14:01 EDT, Patrick Bregman
no flags Details
File: smolt_data (4.76 KB, text/plain)
2012-06-16 14:01 EDT, Patrick Bregman
no flags Details
File: maps (68.94 KB, text/plain)
2012-06-16 14:01 EDT, Patrick Bregman
no flags Details
File: dso_list (12.08 KB, text/plain)
2012-06-16 14:01 EDT, Patrick Bregman
no flags Details
File: build_ids (4.96 KB, text/plain)
2012-06-16 14:01 EDT, Patrick Bregman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1014417 None None None 2012-06-17 17:53:05 EDT

  None (edit)
Description Patrick Bregman 2012-06-16 14:01:25 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        hugin /home/patrick/panorama-zoom/DSC_0035-DSC_0094.pto
comment:        I was stitching a ~60 photo panorama, and used Autopano-SIFT-C (multirow/stacked) as control point detector. I let it add control points, in this it was complaining that it could not optimize any parameters. After all this I decided to remove 2/3 of the images, leaving me with ~20 photos. Hugin crashed on the removal of these photos.
crash_function: __GI_raise
executable:     /usr/bin/hugin
kernel:         3.3.7-1.fc17.x86_64
pid:            24787
pwd:            /tmp
time:           Sat 16 Jun 2012 07:46:16 PM CEST
uid:            1000
username:       patrick
var_log_messages: Jun 16 19:46:36 fedora abrt[26140]: Saved core dump of pid 24787 (/usr/bin/hugin) to /var/spool/abrt/ccpp-2012-06-16-19:46:16-24787 (944492544 bytes)

backtrace:      Text file, 38466 bytes
build_ids:      Text file, 5084 bytes
core_backtrace: Text file, 6234 bytes
dso_list:       Text file, 12371 bytes
maps:           Text file, 70594 bytes
smolt_data:     Text file, 4872 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/patrick/3

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=3
:HOSTNAME=fedora
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=0a94aebde67721d67b28fe3500000013-1339858999.783257-1527456434
:GNOME_KEYRING_CONTROL=/run/user/patrick/keyring-SdflKg
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=patrick
:USERNAME=patrick
:MAIL=/var/spool/mail/patrick
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/patrick
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1564
:LANG=en_US.utf8
:GDM_LANG=en_US.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/patrick
:SHLVL=1
:LOGNAME=patrick
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-sOIlOoZvwQ,guid=e5c47a32906dccc41ef13a6d0000016e
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/patrick
:DISPLAY=:0.0
:XAUTHORITY=/var/run/gdm/auth-for-patrick-4V45hD/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1566,unix/unix:/tmp/.ICE-unix/1566
:GPG_AGENT_INFO=/run/user/patrick/keyring-SdflKg/gpg:0:1
:SSH_AUTH_SOCK=/run/user/patrick/keyring-SdflKg/ssh
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/hugin.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=24787

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 63222                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       63222                63222                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/patrick/.xsession-errors
:pos:	70658
:flags:	0102002
:2:/home/patrick/.xsession-errors
:pos:	70658
:flags:	0102002
:3:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:4:socket:[652056]
:pos:	0
:flags:	02004002
:5:socket:[652075]
:pos:	0
:flags:	02004002
:6:anon_inode:inotify
:pos:	0
:flags:	02004000
:7:socket:[705217]
:pos:	0
:flags:	02004002
:8:/dev/dri/card0
:pos:	0
:flags:	0100002

xsession_errors:
:/usr/share/hugin/data/plugins/top_five.py
:/usr/share/hugin/data/plugins/woa.py
:/usr/share/hugin/data/plugins/shooting_pattern.py
:/usr/share/hugin/data/plugins/crop_cp.py
:/usr/share/hugin/data/plugins/top_five.py
:/usr/share/hugin/data/plugins/woa.py
:/usr/share/hugin/data/plugins/shooting_pattern.py
:/usr/share/hugin/data/plugins/crop_cp.py
:/usr/share/hugin/data/plugins/top_five.py
:/usr/share/hugin/data/plugins/woa.py
:/usr/share/hugin/data/plugins/shooting_pattern.py
:/usr/share/hugin/data/plugins/crop_cp.py
:/usr/share/hugin/data/plugins/top_five.py
:/usr/share/hugin/data/plugins/woa.py
:/usr/share/hugin/data/plugins/shooting_pattern.py
:/usr/share/hugin/data/plugins/crop_cp.py
:hugin: /builddir/build/BUILD/hugin-2011.5.0/src/hugin_base/panodata/Panorama.h:211: virtual const HuginBase::SrcPanoImage& HuginBase::Panorama::getImage(std::size_t) const: Assertion `nr < state.images.size()' failed.
:/usr/share/hugin/data/plugins/top_five.py
:/usr/share/hugin/data/plugins/woa.py
:/usr/share/hugin/data/plugins/shooting_pattern.py
:/usr/share/hugin/data/plugins/crop_cp.py
Comment 1 Patrick Bregman 2012-06-16 14:01:30 EDT
Created attachment 592344 [details]
File: core_backtrace
Comment 2 Patrick Bregman 2012-06-16 14:01:32 EDT
Created attachment 592345 [details]
File: backtrace
Comment 3 Patrick Bregman 2012-06-16 14:01:34 EDT
Created attachment 592346 [details]
File: smolt_data
Comment 4 Patrick Bregman 2012-06-16 14:01:36 EDT
Created attachment 592347 [details]
File: maps
Comment 5 Patrick Bregman 2012-06-16 14:01:38 EDT
Created attachment 592348 [details]
File: dso_list
Comment 6 Patrick Bregman 2012-06-16 14:01:40 EDT
Created attachment 592349 [details]
File: build_ids
Comment 7 Patrick Bregman 2012-06-16 14:40:45 EDT
I do still have the project file and the associated images, though the whole thing is 1.3GByte as a TAR file. Compressed with lrzip and ZPAQ compression I've managed to bring it back to 574MByte. If any of you need this file to help fix this bug, please let me know. I'll upload it somewhere so you're able to download it.
Comment 8 Bruno Postle 2012-06-17 17:50:49 EDT
Thanks for the bug report, I can reproduce and have reported upstream: https://bugs.launchpad.net/hugin/+bug/1014417

I'm going to close this bugzilla because you are using a snapshot from the panorama repository of Hugin snapshots that I maintain: http://repos.fedorapeople.org/repos/bpostle/panorama/

Fedora 17 itself carries the current stable release 2011.4.0-5 which doesn't have this bug.
Comment 9 Bruno Postle 2012-06-20 15:23:24 EDT
The bug is fixed in the hugin-2011.5.0-0.1.20120619hg snapshot package.

Note You need to log in before you can comment on or make changes to this bug.