Bug 832732 - smbd fails to start on F17 x86_64 after downgrade from samba4
smbd fails to start on F17 x86_64 after downgrade from samba4
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Bokovoy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-16 17:52 EDT by Fred Wells
Modified: 2013-01-30 04:17 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-30 04:17:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fred Wells 2012-06-16 17:52:06 EDT
Description of problem:

smbd fails to start on F17 x86_64

Version-Release number of selected component (if applicable):

kernel   3.4.0-1.fc17.x86_64
samba.x86_64   2:3.6.5-86.fc17.1

How reproducible:

Every time

Steps to Reproduce:
1. Enable the service - systemctl enable smb.service
2. Reboot System
3. Check the status - systemctl status smb.service
  
Actual results:

Output form "systemctl status smb.service":

smb.service - Samba SMB Daemon
          Loaded: loaded (/usr/lib/systemd/system/smb.service; enabled)
          Active: failed (Result: exit-code) since Sat, 16 Jun 2012 11:29:38 -0500; 5h 18min ago
         Process: 1060 ExecStart=/usr/sbin/smbd $SMBDOPTIONS (code=exited, status=0/SUCCESS)
        Main PID: 1107 (code=exited, status=1/FAILURE)
          CGroup: name=systemd:/system/smb.service

Jun 16 11:29:38 mypc1 smbd[1060]: [2012/06/16 11:29:38.641351,  0] smbd/server.c:1107(main)
Jun 16 11:29:38 mypc1 smbd[1107]: [2012/06/16 11:29:38.966179,  0] registry/reg_init_basic...mon)
Jun 16 11:29:38 mypc1 smbd[1107]: Failed to initialize the registry: WERR_CAN_NOT_COMPLETE


Expected results:

Expect smbd to be running and status to show Active instead of failed.

Additional info:
Comment 1 Fred Wells 2012-06-16 18:03:12 EDT
Just confirmed that it works fine on identical F17 i686 system - same kernel/samba versions.
Comment 2 Fred Wells 2012-06-18 00:07:21 EDT
Resolved.  I believe this may have occurred as a result of me initially installing samba4, then removing that and installing samba.  The error I received in debug indicated invalid tdb version.  

Steps to resolve:
- yum remove samba samba-common
- rm -rf /var/lib/samba
- yum install samba
Comment 3 Alexander Bokovoy 2012-06-18 02:14:56 EDT
If you have installed samba4 and then downgraded to samba3, see bug 829694 comment 8. 

Please keep this bug open as we'll use it to provide README.Samba4-Samba3.downgrade with instructions on how to behave in such cases.
Comment 4 Alexander Bokovoy 2012-06-18 02:16:09 EDT
I'm changing bug title to reflect documentation fix.
Comment 5 Fred Wells 2012-06-18 09:25:28 EDT
I suppose this affects not only x86_64, but i686 downgrades as well.  Although I can't confirm that, since I never downgraded there.
Comment 6 Andreas Schneider 2013-01-30 04:17:47 EST
Alexander, we NEVER supported downgrades in Samba! The same applies here.

Note You need to log in before you can comment on or make changes to this bug.