Bug 832758 - SetupNetwrks | Can't create BOND without attached network
SetupNetwrks | Can't create BOND without attached network
Status: CLOSED DUPLICATE of bug 842338
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vdsm (Show other bugs)
6.4
x86_64 Linux
unspecified Severity urgent
: rc
: 6.4
Assigned To: Dan Kenigsberg
Meni Yakove
network
:
Depends On:
Blocks: 840699
  Show dependency treegraph
 
Reported: 2012-06-17 04:06 EDT by Meni Yakove
Modified: 2012-07-31 02:21 EDT (History)
13 users (show)

See Also:
Fixed In Version: vdsm-4.9.6-25.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-30 13:17:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log (714.18 KB, application/octet-stream)
2012-06-17 04:07 EDT, Meni Yakove
no flags Details
engine.log (44.96 KB, application/octet-stream)
2012-06-17 04:08 EDT, Meni Yakove
no flags Details
logs (682.84 KB, application/x-gzip)
2012-07-11 05:54 EDT, Martin Pavlik
no flags Details

  None (edit)
Description Meni Yakove 2012-06-17 04:06:09 EDT
Description of problem:
When creating BOND interface without attached network the GUI stack and the BOND interface not created.  

Version-Release number of selected component (if applicable):
vdsm-4.9.6-16.0.el6.x86_64
rhevm-3.1.0_0001-14.el6ev.noarch

How reproducible:
Always

Steps to Reproduce:
1.Open SetupNetwork and create BOND (Do not attach any network to the BOND)
2.Apply
  
Actual results:
BOND not created and GUI stack (Need to refresh)

Expected results:
BOND should be created.
Comment 1 Meni Yakove 2012-06-17 04:07:36 EDT
Created attachment 592389 [details]
vdsm.log
Comment 2 Meni Yakove 2012-06-17 04:08:08 EDT
Created attachment 592390 [details]
engine.log
Comment 3 Itamar Heim 2012-06-17 04:15:21 EDT
logical networks or physical networks.
assuming the latter, i'd say correct behavior is to not allow creating the bond without specifying at least two physical networks it bonds.
Comment 5 Meni Yakove 2012-06-17 04:43:20 EDT
(In reply to comment #3)
> logical networks or physical networks.
> assuming the latter, i'd say correct behavior is to not allow creating the
> bond without specifying at least two physical networks it bonds.

Create BOND using physical networks and do not attached logical networks to it.
If we must attached logical network to the BOND the 'OK' button should be grayed out if we didn't attached any logical network to the BOND.
Comment 6 Mike Kolesnik 2012-07-02 05:14:46 EDT
(In reply to comment #5)
> Create BOND using physical networks and do not attached logical networks to
> it.
> If we must attached logical network to the BOND the 'OK' button should be
> grayed out if we didn't attached any logical network to the BOND.

No need to gray out, this is a VDSM side bug so please update product/component.
Comment 7 Mike Kolesnik 2012-07-02 05:15:24 EDT
Additionally, it might've been fixed already. Igor can you comment please?
Comment 8 Yaniv Kaul 2012-07-02 05:31:04 EDT
(In reply to comment #6)
> No need to gray out, this is a VDSM side bug so please update
> product/component.

Mike, I fully trust your ability to do it
Comment 11 Dan Kenigsberg 2012-07-04 03:03:04 EDT
I believe this has been fixed by http://gerrit.ovirt.org/5487 of vdsm-4.9.6-17.0. Please verify.
Comment 13 Martin Pavlik 2012-07-11 05:53:24 EDT
all important files is attached in attached logs.tar.gz

With vdsm-4.9.6-17.0.el6.x86_64 it is possible to create empty bond. However the bond is started in wrong mode. I selected bond mode1 (active-backup), but bond starts with mode0 (round-robin).

in vdsm.log it is visible that bondmode=1 is sent

Thread-62::DEBUG::2012-07-11 11:27:32,047::BindingXMLRPC::864::vds::(wrapper) client [10.34.63.65]::call setupNetworks with ({}, {'bond1': {'nics': ['p1p1', 'p1p2'], 'options': 'mode=1 miimon=100'}}, {'connectivityCheck': 'true', 'connectivityTimeout': 60000}) {} flowID [1472104]

ifcfg file is created correctly

[root@dell-r210ii-05 ~]# cat /etc/sysconfig/network-scripts/ifcfg-bond1 
DEVICE=bond1
ONBOOT=yes
BOOTPROTO=none
BONDING_OPTS='mode=1 miimon=100'
NM_CONTROLLED=no


but bond is running in mode 0 (roun-robin)

[root@dell-r210ii-05 ~]# cat /proc/net/bonding/bond1
Ethernet Channel Bonding Driver: v3.6.0 (September 26, 2009)

Bonding Mode: load balancing (round-robin)
MII Status: up
MII Polling Interval (ms): 100
Up Delay (ms): 0
Down Delay (ms): 0

Slave Interface: p1p1
MII Status: up
Speed: 1000 Mbps
Duplex: full
Link Failure Count: 1
Permanent HW addr: 90:e2:ba:04:2d:74
Slave queue ID: 0

Slave Interface: p1p2
MII Status: up
Speed: 1000 Mbps
Duplex: full
Link Failure Count: 1
Permanent HW addr: 90:e2:ba:04:2d:75
Slave queue ID: 0


Maybe this is related to following WARNING from vdsm.log 

MainProcess|Thread-62::WARNING::2012-07-11 11:27:32,508::configNetwork::83::root::(ifup) /etc/sysconfig/network-scripts/ifup-eth: line 136: echo: write error: Operation not permitted
Comment 14 Martin Pavlik 2012-07-11 05:54:00 EDT
Created attachment 597519 [details]
logs
Comment 15 Igor Lvovsky 2012-07-30 13:17:25 EDT

*** This bug has been marked as a duplicate of bug 842338 ***

Note You need to log in before you can comment on or make changes to this bug.