Bug 832764 - [abrt] solfege-3.20.4-2.fc17: solfege:39:<module>:OSError: [Errno 2] No such file or directory: '/share/solfege'
[abrt] solfege-3.20.4-2.fc17: solfege:39:<module>:OSError: [Errno 2] No such ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: solfege (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christian Krause
Fedora Extras Quality Assurance
abrt_hash:d3d3b80218f5ed8ef25186a9a11...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-17 05:18 EDT by Arthur
Modified: 2012-09-27 01:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-27 00:28:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: smolt_data (2.20 KB, text/plain)
2012-06-17 05:18 EDT, Arthur
no flags Details

  None (edit)
Description Arthur 2012-06-17 05:18:26 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python /bin/solfege
executable:     /bin/solfege
kernel:         3.4.0-1.fc17.i686.PAE
time:           Вс. 17 июня 2012 15:16:48
uid:            1000
username:       chewbacca

smolt_data:     Binary file, 2254 bytes

backtrace:
:solfege:39:<module>:OSError: [Errno 2] No such file or directory: '/share/solfege'
:
:Traceback (most recent call last):
:  File "/bin/solfege", line 39, in <module>
:    os.chdir(os.path.join(prefix, "share", "solfege"))
:OSError: [Errno 2] No such file or directory: '/share/solfege'
:
:Local variables in innermost frame:
:__builtins__: <module '__builtin__' (built-in)>
:__file__: '/bin/solfege'
:traceback: <module 'traceback' from '/usr/lib/python2.7/traceback.pyc'>
:textwrap: <module 'textwrap' from '/usr/lib/python2.7/textwrap.pyc'>
:absolute_import: _Feature((2, 5, 0, 'alpha', 1), (2, 7, 0, 'alpha', 0), 16384)
:__package__: None
:sys: <module 'sys' (built-in)>
:prefix: '/'
:__builtin__: <module '__builtin__' (built-in)>
:time: <module 'time' from '/usr/lib/python2.7/lib-dynload/timemodule.so'>
:__name__: '__main__'
:os: <module 'os' from '/usr/lib/python2.7/os.pyc'>
:__doc__: None
Comment 1 Arthur 2012-06-17 05:18:31 EDT
Created attachment 592399 [details]
File: smolt_data
Comment 2 Martin Tarenskeen 2012-08-31 15:23:38 EDT
1. Try to start solfege from the commandline
2. Solfege does not start, but I see the error message in my terminal

Guessing: something went wrong with prefix /usr vs / ?
/bin instead of /usr/bin is ok. But /share does not exist on my system/ 
(I tried to create a symlink from /usr/share/ to /share. 
After that I could start solfege. But I guess that's not the proper way
to fix this?)


Package: solfege-3.20.6-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 3 Christian Krause 2012-09-01 15:28:08 EDT
The problem is caused by a change in F17: http://fedoraproject.org/wiki/Features/UsrMove :

- /bin is now a symlink to /usr/bin
- /bin is earlier in the PATH than /usr/bin
- so when "solfege" is executed, it's ARGV[0] will be /bin/solfege
- due to some magic in solfege to determine the prefix for /share (usually /usr), it searches now in /share, since ARGV[0] does not contain /usr anymore

Workaround:
- start "/usr/bin/solfege" (and not "solfege") in a terminal

I have already a patch ready and I'll push out a new solfege package tomorrow.
Comment 4 Fedora Update System 2012-09-02 20:18:15 EDT
solfege-3.20.6-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/solfege-3.20.6-2.fc18
Comment 5 Fedora Update System 2012-09-02 20:19:41 EDT
solfege-3.20.6-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/solfege-3.20.6-2.fc17
Comment 6 Fedora Update System 2012-09-03 18:57:45 EDT
Package solfege-3.20.6-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing solfege-3.20.6-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-13273/solfege-3.20.6-2.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-09-27 00:28:18 EDT
solfege-3.20.6-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2012-09-27 01:00:28 EDT
solfege-3.20.6-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.