Bug 832772 - Prelink - can't install compiled firefox.
Prelink - can't install compiled firefox.
Status: CLOSED DUPLICATE of bug 741071
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-17 05:55 EDT by Jerzy Spendel
Modified: 2012-07-31 10:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-31 10:06:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerzy Spendel 2012-06-17 05:55:33 EDT
Description of problem:
I have downloader .src.rpm of Firefox by:
yumdownloader --source firefox

I have compiled this source package with rpmbuild --rebuild <path_to_src_of_firefox>. Installing compiled package ended with an error.


Version-Release number of selected component (if applicable):
13.01

How reproducible:
Easy

Steps to Reproduce:
1. yumdownloader --source firefox
2. rpmbuild --rebuild <path_to_firefox.src.rpm>
3. yum install <path_to_firefox.rpm>
  
Actual results:

[jerzy@FedoraJ ~]$ sudo yum install '/home/jerzy/rpmbuild/RPMS/x86_64/firefox-13.0-1.fc17.x86_64.rpm' 
Loaded plugins: langpacks, presto, refresh-packagekit
Examining /home/jerzy/rpmbuild/RPMS/x86_64/firefox-13.0-1.fc17.x86_64.rpm: firefox-13.0-1.fc17.x86_64
Marking /home/jerzy/rpmbuild/RPMS/x86_64/firefox-13.0-1.fc17.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package firefox.x86_64 0:13.0-1.fc17 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package     Arch       Version           Repository                       Size
================================================================================
Installing:
 firefox     x86_64     13.0-1.fc17       /firefox-13.0-1.fc17.x86_64      25 M

Transaction Summary
================================================================================
Install  1 Package

Total size: 25 M
Installed size: 25 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : firefox-13.0-1.fc17.x86_64                                   1/1 
Error unpacking rpm package firefox-13.0-1.fc17.x86_64
error: unpacking of archive failed on file /usr/lib64/firefox/firefox;4fdda179: cpio: Digest mismatch
  Verifying  : firefox-13.0-1.fc17.x86_64                                   1/1 

Failed:
  firefox.x86_64 0:13.0-1.fc17                                                  

Complete!
[jerzy@FedoraJ ~]$ 


Expected results:

Installing without errors.
Additional info:
Comment 1 Martin Stransky 2012-06-18 02:14:06 EDT
It's a problem with prelink package, remove it or disable prelink when building firefox.
Comment 2 Martin Stransky 2012-07-31 10:06:46 EDT

*** This bug has been marked as a duplicate of bug 741071 ***

Note You need to log in before you can comment on or make changes to this bug.