Bug 832819 - Please revert fix for bug 753862
Please revert fix for bug 753862
Status: CLOSED DUPLICATE of bug 823156
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
rawhide
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-17 12:09 EDT by Josh Davis
Modified: 2012-06-18 11:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-18 05:52:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Davis 2012-06-17 12:09:37 EDT
Description of problem: 
ddate was removed from the standard build of util-linux

How reproducible:
Always

Steps to Reproduce:
1. ddate
2.
3.
  
Actual results:
ddate: command not found

Expected results:
Today is Pungenday, the 22nd day of Confusion in the YOLD 3178

Additional info:
After upgrading, my system was broken.  I rely on this utility.  The suggested workaround to download the source for a core package like util-linux and compile it myself with --enable-ddate is not acceptable.  If I was interested in compiling and maintaining my own custom versions of core linux packages, I would have chosen Gentoo.  My workaround is to revert back to my previous version until such time as util-linux is fixed.

If any user is offended by the presence of ddate or wishes to reclaim the 8k or so of space it takes up, then provide them with an option to disable it.  When making changes such as this, it would be better to err on the side of not breaking users' systems.  Please see this thread for information on why the suggestion to remove ddate from util-linux was rejected the last time it came up: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=149321
Comment 1 Karel Zak 2012-06-18 05:52:25 EDT

*** This bug has been marked as a duplicate of bug 823156 ***
Comment 2 Josh Davis 2012-06-18 08:31:43 EDT
This bug is closed as duplicate of a bug marked as "WONTFIX"???  Does this mean that no one should rely on the existence of any utility in util-linux, because they may be removed or disabled at any time?
Comment 3 Jonas Wielicki 2012-06-18 10:52:06 EDT
(In reply to comment #2)
> This bug is closed as duplicate of a bug marked as "WONTFIX"???  Does this
> mean that no one should rely on the existence of any utility in util-linux,
> because they may be removed or disabled at any time?

Experienced the same, see my comment on the duplicate'd bug <https://bugzilla.redhat.com/show_bug.cgi?id=823156#c3>.

I am still startled by the blank offense Karel Zak is giving the community by just removing tools without actual rationale. I wish he would finally see that the only thing he gains is rejection by fellow linuxers.

I for myself reverted to fedora 16 for now, not only for this reason but also because of issues with the gcc and other rather minor problems.
Comment 4 Josh Davis 2012-06-18 11:09:13 EDT
(In reply to comment #3)
> I am still startled by the blank offense Karel Zak is giving the community
> by just removing tools without actual rationale. I wish he would finally see
> that the only thing he gains is rejection by fellow linuxers.
> 
> I for myself reverted to fedora 16 for now, not only for this reason but
> also because of issues with the gcc and other rather minor problems.

The rationale seems to be that one user accidentally typed ddate instead of date and was so surprised by the result that he filed a bug.  Instead of reminding this user that it's a good idea to take a look at the command you have typed before hitting enter, Karel Zak's solution was to break util-linux for the users who rely on ddate.  This makes no sense to me.

There are other distos out there with maintainers who give a hoot about whether the changes they make break their users' system, and they are including util-linux with ddate enabled.  So if this really won't be fixed, then I will probably switch to one of those.
Comment 5 Jonas Wielicki 2012-06-18 11:10:24 EDT
To make this discussion less attackable, I'd suggest to continue it in bug 823156.

Note You need to log in before you can comment on or make changes to this bug.