Bug 832820 - In dual screen setup with wide external monitor small windows cannot be freely moved
In dual screen setup with wide external monitor small windows cannot be freel...
Status: CLOSED DUPLICATE of bug 746462
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
17
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-17 12:13 EDT by oliver
Modified: 2013-02-11 14:24 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-11 14:24:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot illustrating setup and how much left windows can be moved (2.17 MB, image/png)
2012-06-17 13:22 EDT, oliver
no flags Details

  None (edit)
Description oliver 2012-06-17 12:13:37 EDT
Description of problem:

I am using Gnome 3 on a dual screen setup with a 1280x800 internal laptop screen below a 2048x1152 external monitor (so logical screen layout corresponds to physical arrangement of the screens).  On the larger external screen, small windows cannot be moved to the left border of the screen, there appears a barrier which is larger for smaller windows, and disappears only for windows wider than about 2/3 of the width of the large screen.

Similarly, creating a wide window on the big monitor, aligning it to the left edge of the screen and then resizing the window makes it suddenly jump to the right in steps that appear to correspond to a discrete set of movement barriers.

In all other respects, the dual-screen setup seems to work fine.

Version-Release number of selected component (if applicable):
I am testing with the Fedora 17 live CD (32 bit).

How reproducible:
Always

Steps to Reproduce:
1. Boot up with screens described above attached.
2. Start Display Settings dialog
3. In Display Dettings dialog, drag Laptop screen below external screen (see screenshot attached)
  
Actual results:
Wierd window placement barriers as described above

Expected results:
A window can be placed anywhere on any of the monitors, no matter how wide it is.

Additional info:
This setup is working perfectly on Fedora 14.  On Fedora 15, there was similar wierdness in connection to other display-driver and Gnome 3-related problems.  I am now reevaluating if I can finally upgrade to newer Fedora, but this is a killer bug that makes my standard workplace setup unusable.
Comment 1 oliver 2012-06-17 13:22:50 EDT
Created attachment 592456 [details]
Screenshot illustrating setup and how much left windows can be moved

All windows on the upper screen have been moved as much left as possible.  It appears that this leftmost position is determined by some forced alignment of the right windows border at some arbitrary imaginary line on the screen.  All windows at least as wide than the location of this imaginary line can be freely moved, all windows less wide experience the described barrier.
Comment 2 oliver 2012-11-30 02:57:03 EST
Just for the record: This bug persists in Fedora 18 beta as of today.

Cinnamon and MATE do not show this bug, so everything is fine from my point of view.  But maybe it would be worth fixing anyway as gnome shell is still the default in Fedora and someone might still be using it.
Comment 3 Christopher Beland 2013-02-11 14:11:42 EST
It sounds like Bug 711479 may be related to this one; it happens in the same dual monitor configuration.
Comment 4 Christopher Beland 2013-02-11 14:24:36 EST

*** This bug has been marked as a duplicate of bug 746462 ***

Note You need to log in before you can comment on or make changes to this bug.