Bug 832822 - broken update path
Summary: broken update path
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs-bbdb
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Göran Uddeborg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-06-17 16:24 UTC by Enrico Scholz
Modified: 2012-07-19 09:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-19 09:18:43 UTC


Attachments (Terms of Use)

Description Enrico Scholz 2012-06-17 16:24:44 UTC
Description of problem:

# yum upgrade
Error: Package: 1:emacs-bbdb-el-2.35-6.fc17.noarch (@base)
           Requires: emacs-bbdb = 1:2.35-6.fc17
           Removing: 1:emacs-bbdb-2.35-6.fc17.noarch (@base)
               emacs-bbdb = 1:2.35-6.fc17
           Updated By: 1:emacs-bbdb-2.35-7.fc17.noarch (updates)
               emacs-bbdb = 1:2.35-7.fc17


This happens because of missing Provides:/Obsoletes: in emacs-bbdb.

Btw: please avoid such packaging changes (removal of -el subpackage) during a release; it's a non-trivial modification without much use and its effects are difficultly to overview.

Comment 1 Göran Uddeborg 2012-07-04 22:06:17 UTC
Thanks for your report.  I can't answer for Jonathan's reasoning when doing the packaging change in a release branch.  I'm only his new co-maintainer.  But given that it is done, it would probably just make things worse to try to revert it.  I'll add the additional tag.

Comment 2 Göran Uddeborg 2012-07-05 15:41:06 UTC
There actually is a Provides/Obsoletes in release 7 already.  But unfortunately, it obsoleted versions with release <= 6.  When a dist tag is added, as in 6.fc17, that package is considered greater than 6, so the obsoleting didn't happen.  I'll change it to release < 7 instead.

Comment 3 Fedora Update System 2012-07-05 15:56:59 UTC
emacs-bbdb-2.35-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/emacs-bbdb-2.35-8.fc17

Comment 4 Fedora Update System 2012-07-05 23:38:16 UTC
Package emacs-bbdb-2.35-8.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing emacs-bbdb-2.35-8.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10282/emacs-bbdb-2.35-8.fc17
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2012-07-19 09:18:43 UTC
emacs-bbdb-2.35-8.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.