Bug 832872 - Install of F17 onto MDADM controlled softraid on IMSM disk fails at GRUB2 complaining about LDM
Install of F17 onto MDADM controlled softraid on IMSM disk fails at GRUB2 com...
Status: CLOSED DUPLICATE of bug 743273
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 01:30 EDT by Jens Tingleff
Modified: 2012-08-08 14:50 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-08 14:50:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
tar -cj of /tmp/*log after install. Juicy error message in program.log (62.84 KB, application/x-bzip)
2012-06-18 01:30 EDT, Jens Tingleff
no flags Details
Logs of successful F16 install, no error, no message about LDM (62.84 KB, application/octet-stream)
2012-06-18 01:33 EDT, Jens Tingleff
no flags Details
program.log pulled out of the archive (261.52 KB, text/plain)
2012-07-13 20:17 EDT, Jesse Keating
no flags Details

  None (edit)
Description Jens Tingleff 2012-06-18 01:30:33 EDT
Created attachment 592519 [details]
tar -cj of /tmp/*log after install. Juicy error message in program.log

Description of problem: Install runs fine (showing LVM disk lv partitions on top of MDADM which is on top of IMSM fake-RAID disks). At the last stage (writing bootloader) it reports that it failed to write bootloader and the system might not boot. At reboot the system does indeed not boot. 

I chose the default boot loader install point (the MDADM device, in this case /dev/md126)

I get an error message in program.log about grub2-bios-setup not liking LDM 

Version-Release number of selected component (if applicable):


How reproducible: Every time (tried Live and DVD versions)


Steps to Reproduce:
1. RAID10 setup on IMSM as only disk, appears as /dev/md126 in Linux
2. install Windows 7 in primary partition(s)
2. Make extended partition with LVM pv and 250 MB log. partition for /boot
3. install F17 in volume groups from LVM, mounting /boot on logical partition
4. accept default choice for bootloader install: "/dev/md126." (with ., not ")
5. At end of install, warning "There was an error installing the bootloader"
6. click reboot (which is done, not like the bad old days)
7. get dropped into GRUB prompt
  
Actual results: GRUB complains about unrecognised file system
Comment 1 Jens Tingleff 2012-06-18 01:33:21 EDT
Created attachment 592520 [details]
Logs of successful F16 install, no error, no message about LDM
Comment 2 Jesse Keating 2012-07-13 20:17:08 EDT
Created attachment 598194 [details]
program.log pulled out of the archive
Comment 3 Mads Kiilerich 2012-07-31 16:13:44 EDT
(In reply to comment #1)
> Created attachment 592520 [details]
> Logs of successful F16 install, no error, no message about LDM

No; that is logs from F17, exactly the same as 592519.

In both cases:

15:45:02,656 INFO program: Running... grub2-install --no-floppy /dev/md126
15:45:05,590 ERR program: /usr/sbin/grub2-bios-setup: warning: this LDM has no Embedding Partition; embedding won't be possible.
15:45:05,596 ERR program: /usr/sbin/grub2-bios-setup: warning: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
15:45:05,596 ERR program: /usr/sbin/grub2-bios-setup: error: will not proceed with blocklists.

It really looks like grub has/had a real or perceived problem with LDM.

Could you try to run
  yum update grub2
to get beta6 and run grub2-install manually?
Comment 4 Peter Jones 2012-08-08 14:50:28 EDT

*** This bug has been marked as a duplicate of bug 743273 ***

Note You need to log in before you can comment on or make changes to this bug.