Bug 832893 - Password dialog is missing password field. See picture.
Password dialog is missing password field. See picture.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-plasma-networkmanagement (Show other bugs)
18
Unspecified Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Jan Grulich
Fedora Extras Quality Assurance
: Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 03:28 EDT by Oliver Sampson
Modified: 2013-03-12 04:26 EDT (History)
13 users (show)

See Also:
Fixed In Version: kde-plasma-networkmanagement-0.9.0.5-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-03 17:34:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Snapshot of the faulty dialog (36.70 KB, image/png)
2012-06-18 03:28 EDT, Oliver Sampson
no flags Details
Screenshot with networkmanagement-*-0.9.0.3-2-fc16 (99.18 KB, image/png)
2012-06-27 02:52 EDT, Oliver Sampson
no flags Details
Screenshot with kde-plasma-networkmanagement-0.9.0.4 (90.94 KB, image/png)
2012-07-31 03:34 EDT, Oliver Sampson
no flags Details
Big password dialog. No password field. (301.36 KB, image/png)
2012-08-01 02:41 EDT, Oliver Sampson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 299868 None None None 2012-06-18 11:32:18 EDT

  None (edit)
Description Oliver Sampson 2012-06-18 03:28:35 EDT
Created attachment 592545 [details]
Snapshot of the faulty dialog

Description of problem:
The dialog field for entering the WiFi secret doesn't show the input field for typing a password. Password can't be entered.

Version-Release number of selected component (if applicable):


How reproducible:
Right now very reproducible. I can't get it via a completely updated system, a reboot, or whatever to do anythign else. 

Steps to Reproduce:
This isn't reproducible, but this is the second time it's happened. After the last time, I updated the system via LAN, and the problem disappeared.
  
Actual results:


Expected results:


Additional info:
I've set the priority to "Urgent" because without this dialog, wireless networking is crippled.
Comment 1 Dan Winship 2012-06-18 09:08:49 EDT
that snapshot is from the KDE NetworkManager UI. reassigning to kdenetwork, which I'm guessing is the right component for that...
Comment 2 Lukáš Tinkl 2012-06-18 11:29:43 EDT
https://bugs.kde.org/show_bug.cgi?id=299868#c11 has a patch reportedly, can you try that one?
Comment 3 Rex Dieter 2012-06-18 14:22:34 EDT
Test builds:

kde-plasma-networkmanagement-0.9.0.3-2.fc17 http://koji.fedoraproject.org/koji/buildinfo?buildID=326101 

kde-plasma-networkmanagement-0.9.0.3-2.fc16 http://koji.fedoraproject.org/koji/buildinfo?buildID=326110
Comment 4 Oliver Sampson 2012-06-18 19:59:17 EDT
FWIW, I have a workaround for this problem.

1) Log out.
2) Log into Gnome.
3) Enter password at prompt.
4) Log out.
5) Log into KDE.
Comment 5 Lukáš Tinkl 2012-06-25 06:57:17 EDT
Do those test builds mentioned in comment #3 work for you?
Comment 6 Oliver Sampson 2012-06-26 13:39:32 EDT
Oops! I must admit that I overlooked that comment.

So, I'm new to patching things in Linux. A bit of googling says "patch" is the answer, but I don't have the source code downloaded to patch against. 

Assuming that I only need to download and build the KDE subsystem, this looks like the right place to start:

http://techbase.kde.org/Getting_Started/Build#Source

I'll report back after I get it patched and tested.
Comment 7 Kevin Kofler 2012-06-26 16:38:02 EDT
You don't have to patch it yourself, you should just test the linked builds.
Comment 8 Oliver Sampson 2012-06-27 02:52:10 EDT
Created attachment 594696 [details]
Screenshot with networkmanagement-*-0.9.0.3-2-fc16
Comment 9 Oliver Sampson 2012-06-27 03:00:55 EDT
The rpms didn't solve the problem. (New screenshot attached.) I upgraded the rpms, and restarted NetworkManager. That didn't work, so I logged out and logged back in, and that didn't work.

There are some more details to this, which may be of interest:

I use the wireless network primarily in two locations, at home and at the university. At home, the system works flawlessly. At the University, the system uses "Eduroam." which also uses a type of certificate based authentication. http://www.eduroam.org/ After I restart the NetworkManager, the password is pulled from the KWallet and the system connects. Then after some short period of time (like 10 or 30s), I get prompted for my password with the faulty dialog. I don't think that Eduroam is the problem, because the system works flawlessly under Gnome. 

When logging into Gnome, I type havet to type in my password, and it is stored and kept, and I'm not continually asked for my password.

I'll be happy to give any other details that might be required to help solve this problem.
Comment 10 Timothy Murphy 2012-07-15 20:14:40 EDT
I've never, ever been able to enter a password when this "Secrets" window comes up. 
Admittedly this doesn't happen very often, but when it does I usually re-boot.
Comment 11 Fedora Update System 2012-07-30 08:55:55 EDT
kde-plasma-networkmanagement-0.9.0.4-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9.0.4-1.fc17
Comment 12 Fedora Update System 2012-07-30 08:56:06 EDT
kde-plasma-networkmanagement-0.9.0.4-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9.0.4-1.fc16
Comment 13 Fedora Update System 2012-07-30 18:22:20 EDT
Package kde-plasma-networkmanagement-0.9.0.4-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-plasma-networkmanagement-0.9.0.4-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11276/kde-plasma-networkmanagement-0.9.0.4-1.fc16
then log in and leave karma (feedback).
Comment 14 Oliver Sampson 2012-07-31 03:32:41 EDT
The proposed solution, kde-plasma-networkmanagement-0.9.0.4-1.fc16.i686 didn't work. :-(
Comment 15 Oliver Sampson 2012-07-31 03:34:12 EDT
Created attachment 601453 [details]
Screenshot with kde-plasma-networkmanagement-0.9.0.4
Comment 16 Rex Dieter 2012-07-31 08:21:20 EDT
it's basically the default size of the widget seems too small.  Another simple workaround is to resize it (grab the bottom/right of the dialog and drag).
Comment 17 Rex Dieter 2012-07-31 08:21:56 EDT
updating summary to match reality
Comment 18 Oliver Sampson 2012-08-01 02:41:10 EDT
Created attachment 601658 [details]
Big password dialog. No password field.
Comment 19 Oliver Sampson 2012-08-01 02:42:51 EDT
Updating Summary to match reality.
Comment 20 Lukáš Tinkl 2012-08-03 06:04:13 EDT
Looks like the bug is not entirely fixed yet in upstream :/
Comment 21 Fedora Update System 2012-08-05 17:29:24 EDT
kde-plasma-networkmanagement-0.9.0.4-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Rex Dieter 2012-08-05 17:41:33 EDT
re-opening
Comment 23 Fedora Update System 2012-08-09 19:11:39 EDT
kde-plasma-networkmanagement-0.9.0.4-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 24 Oliver Sampson 2012-08-10 03:50:12 EDT
How is this closed? The bug still persists with kde-plasma-networkmanagement-0.9.0.4-1.fc16.
Comment 25 Lukáš Tinkl 2012-08-10 04:55:49 EDT
Automatically by a script, we know it's not fixed yet
Comment 26 Oliver Sampson 2012-08-10 05:11:17 EDT
Oh, cool. Thanks. I'm still new here. :$
Comment 27 Rodrigo Gudino 2012-09-25 12:49:35 EDT
Corrected! Listo! Fertig! The only necessary thing to do is to forget that connection, and to introduce the password again as a new connection. And thats it. I asume it has to be the incompatibility of kde wallet with another subsystem of the system-network-config. But that's all you have to do for fixing it

Cheers!
Comment 28 Oliver Sampson 2012-09-28 03:08:38 EDT
Thank you Rodrigo! Deleting the connection and reconfiguring it did the trick! It's solved.
Comment 29 Oliver Sampson 2012-10-01 08:09:56 EDT
Well, I guess I counted my chickens before they were hatched. My system just asked for the password again, and again it is without the password field. So although there seems to be a workaround as described by Rodrigo, the problem isn't truly solved.
Comment 30 Lukáš Tinkl 2012-10-02 11:20:12 EDT
Just out of curiosity, do you have ksecrets installed? 

$ rpm -q ksecrets
Comment 31 Kevin Kofler 2012-10-02 11:32:38 EDT
Just to be clear, ksecrets should NOT be installed. (It doesn't work.)
Comment 32 Oliver Sampson 2012-10-02 11:43:31 EDT
No, I don't have ksecrets installed:

$ rpm -q ksecrets
package ksecrets is not installed
Comment 33 Lukáš Tinkl 2012-10-02 11:45:24 EDT
Yes I know, that's why I asked Kevin ;)
Comment 34 Kevin Kofler 2012-10-02 12:10:51 EDT
I know you know. :-) But users could have misunderstood your comment #30 as a request to install that broken package. :-(
Comment 35 Fedora Update System 2012-10-05 08:31:35 EDT
kde-plasma-networkmanagement-0.9.0.5-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9.0.5-1.fc16
Comment 36 Fedora Update System 2012-10-05 23:45:40 EDT
Package kde-plasma-networkmanagement-0.9.0.5-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-plasma-networkmanagement-0.9.0.5-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15489/kde-plasma-networkmanagement-0.9.0.5-1.fc16
then log in and leave karma (feedback).
Comment 37 Oliver Sampson 2012-11-12 05:17:46 EST
This seems to be fixed now. Thanks!
Comment 38 Lukáš Tinkl 2012-11-14 09:30:19 EST
Has been pushed to stable long ago...
Comment 39 Jan Grulich 2013-02-13 06:59:31 EST
Seems that this bug is still present in kde-plasma-networkmanagement-0.9.0.7 but I already have a patch for this problem. It happens only with Wpa2 enterprise. I think it will be fixed in 0.9.0.8 or I can backport this fix into 0.9.0.7 build.
Comment 40 Rex Dieter 2013-02-13 14:07:33 EST
I'm ok with any of the following:

1. wait for 0.9.0.8
2. your patching 0.9.0.7
3. if patch is committed upstream, my including the patch in a 0.9.0.7 build (provided you give me a commit reference/hash)
Comment 41 Fedora Update System 2013-02-19 17:37:14 EST
kde-plasma-networkmanagement-0.9.0.7-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9.0.7-2.fc17
Comment 42 Fedora Update System 2013-02-19 17:38:20 EST
kde-plasma-networkmanagement-0.9.0.7-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9.0.7-2.fc18
Comment 43 Fedora Update System 2013-02-21 00:39:26 EST
Package kde-plasma-networkmanagement-0.9.0.7-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-plasma-networkmanagement-0.9.0.7-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2778/kde-plasma-networkmanagement-0.9.0.7-2.fc17
then log in and leave karma (feedback).
Comment 44 Fedora Update System 2013-03-03 17:34:44 EST
kde-plasma-networkmanagement-0.9.0.7-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 45 Fedora Update System 2013-03-12 04:26:03 EDT
kde-plasma-networkmanagement-0.9.0.7-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.