Bug 832900 - The url of applications on "My Applications" page will overlap.
The url of applications on "My Applications" page will overlap.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Steve Goodwin
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-18 03:41 EDT by Yujie Zhang
Modified: 2015-05-14 21:12 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-13 19:44:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot1 (88.58 KB, image/png)
2012-06-18 03:41 EDT, Yujie Zhang
no flags Details
screenshot2 (98.39 KB, image/png)
2012-06-20 05:05 EDT, Yujie Zhang
no flags Details
screenshot3 (111.09 KB, image/png)
2012-06-21 04:01 EDT, Yujie Zhang
no flags Details
screenshot4 (135.61 KB, image/png)
2012-06-25 00:44 EDT, Yujie Zhang
no flags Details

  None (edit)
Description Yujie Zhang 2012-06-18 03:41:14 EDT
Created attachment 592547 [details]
screenshot1

Description of problem:

After I created 3 applications and check the "My Applications" page, the url of applications will overlap when I use IPhone4S.

Version-Release number of selected component (if applicable):

int.openshift.redhat.com

How reproducible:always


Steps to Reproduce:
1.Go to openshift website and created 3 applications
2.Check the "My Applications" page.
3.
  
Actual results:

The url of application will overlap on IPhone4S.

Expected results:

The url of application should not overlap on IPhone4S.

Additional info:
Comment 1 John Poelstra 2012-06-19 13:20:57 EDT
clayton reviewing today
Comment 2 Steve Goodwin 2012-06-19 18:25:16 EDT
Fixed with commit fff20671d2eb0c456aabfc11bc2de9cb01c41530
Comment 3 Yujie Zhang 2012-06-20 05:05:07 EDT
(In reply to comment #2)
Not sure if the commit is finished, tested on devenv_1859 and int.openshift.redhat.com, the url still can overlaps, especially when using long application name.Details please in attachment.
Comment 4 Yujie Zhang 2012-06-20 05:05:38 EDT
Created attachment 593153 [details]
screenshot2
Comment 5 Steve Goodwin 2012-06-20 11:00:22 EDT
My commit updates were not included in the recent INT build. Once INT build is updated those changes will be available to test.

moving back to on_qa
Comment 6 Yujie Zhang 2012-06-21 03:28:08 EDT
(In reply to comment #5)
Tested this issue on int.openshift.redhat.com today, it has been fixed now.
Comment 7 Yujie Zhang 2012-06-21 04:00:54 EDT
(In reply to comment #5)
Just tried this link on IPad2 again, found it still will overlaps, I think this is related to how I handle the IPad2, since the screen can turn around automaticaly. Details see in attachment.
Comment 8 Yujie Zhang 2012-06-21 04:01:36 EDT
Created attachment 593380 [details]
screenshot3
Comment 9 Clayton Coleman 2012-06-21 13:03:51 EDT
On my iPad 3 on INT I don't see this behavior.  When you refresh the page, does the text get cut off correctly?  IF so then I think this is going to be CANTFIX (browser specific behavior).
Comment 10 Steve Goodwin 2012-06-21 13:08:07 EDT
lowering priority/severity
Comment 11 Yujie Zhang 2012-06-25 00:41:41 EDT
(In reply to comment #10)
Tested this issue on stage on firefox12, still has this issue, not sure if it can be fixed, I think it's not only existing on tablet now.Details see in attachment.
Comment 12 Yujie Zhang 2012-06-25 00:44:25 EDT
Created attachment 594096 [details]
screenshot4
Comment 13 Steve Goodwin 2012-07-05 15:31:02 EDT
fix commit aaf62dc63ef1314539f31cb2406a8ff3ac1a7bea
Comment 14 Mengjiao Gao 2012-07-11 06:43:48 EDT
Tested on Iphone, firefox and Chrome on devenv_1884, they are displayed without overlap.So I changed it to verified.

Note You need to log in before you can comment on or make changes to this bug.